CoolBasic/Editori ja asetukset

Kohteesta Wikikirjasto
Siirry navigaatioon Siirry hakuun

Käyttöliittymä[muokkaa | muokkaa wikitekstiä]

Ikkunan oikeassa litassa näet koodiselaimen. Oletuksellisesti se näyttää funktiot, luokat ja tyypit. Koodiselaimen yläreunassa on seuraavat painikkeet:

  • Ensimmäinen kuvake Listaa koodin funktiot, luokat ja tyypit
  • Toinen kuvake Listaa koodin vakiot, muuttujat ja kirjanmerkit (label)
  • Viimeinen kuvake Kysymysmerkki. Avaa manuaalin

Manuaali[muokkaa | muokkaa wikitekstiä]

Tämä manuaali avautuu joko valikosta Help/Index, valikosta Help/Context tai painamalla F1. Jos painat F1 jonkun avainsanan (oletuksena sininen) kohdalla, ohje siirtyy kyseisen komennon oppaaseen.

Kuvan kohteiden selitykset:

  1. Laajennuspainike. Tämä nuoli laajentaa manuaalin koko ikkunaan. Manuaalia saattaa olla mukavampi lukea näin. Samasta painikkeesta saat palattua normaalinäkymään, jossa ohjeikkuna puolittaa ruudun.
  2. Selaa ohjesivuja taakse päin. Toimii samaan tapaan kuin Internet-selain.
  3. Selaa ohjesivuja eteen päin. Toimii samaan tapaan kuin Internet-selain.
  4. Palaa etusivulle.
  5. Etsintätoiminnon hakusana. Voit etsiä manuaalista sanoilla ja lauseilla.
  6. ETSI-painike. Aloittaa etsinnän.
  7. Palkki näyttää etsinnän etenemisen.
  8. Tämä painike sulkee manuaalin.

Oppitunnit (Learning Center)[muokkaa | muokkaa wikitekstiä]

Kun ensimmäisen kerran käynnistät CoolBasicin, näet tällaisen ikkunan:

Se on tarkoitettu opastamaan uusia käyttäjiä. Jos otat raksin pois ruudusta, tätä ikkunaa ei enää näytetä kun CoolBasic käynnistetään. Mikäli haluat myöhemmin palata oppitunteihin, se onnistuu valikosta Help/Learning Center tai painamalla F8 editorinäkymässä. Jos haluat, että ikkuna näytetään taas joka kerta kun CoolBasic käynnistyy, pistä raksi ruutuun "Show me at CoolBasic start-up".

Editorin asetukset[muokkaa | muokkaa wikitekstiä]

Voit muuttaa editorin editorin asetuksia vastaamaan tottumuksiasi valikosta Files/Preferences:

Täältä voit säätää värejä (joista lisää myöhemmin tässä luvussa) ja editointitottumuksia.

Use Window Transparency[muokkaa | muokkaa wikitekstiä]

Mikäli tämä kohta on valittuna, editori näyttää Asetukset-, Etsi-, Tietoja- ja LearningCenter-ikkunat läpinäkyvinä. Efekti toimii ainoastaan Windows 2000, XP ja Vista.

Continue Session at Start-up[muokkaa | muokkaa wikitekstiä]

Kun CoolBasic käynnistetään seuraavan kerran, ladataan automaattisesti ne tiedostot joita ei suljettu kun CoolBasic lopetettiin. Eli voit käytännössä jatkaa siihen mihin jäit.

Open Files Only Once[muokkaa | muokkaa wikitekstiä]

Estää avaamasta samaa tiedostoa uuteen välilehteen, jos se on jo auki.

Remember Window Settings[muokkaa | muokkaa wikitekstiä]

Tallentaa ikkunan sijainnin niin, että kun CoolBasic käynnistetään seuraavan kerran, ikkuna on samassa kohtaa työpöytää kuin viimeksi.

Autosave on Each RUN[muokkaa | muokkaa wikitekstiä]

Tallentaa lähdekoodin automaattisesti joka kerta kun ohjelmaa testataan F5:llä. Jos jokin menee vikaan (esimerkiksi ohjelma tai järjestelmä kaatuu), ei tietoja mennyt hukkaan.

Sort Browser Items[muokkaa | muokkaa wikitekstiä]

Mikäli tämä kohta on valittu, koodiselaimen listaamat funktiot, tyypit, kirjanmerkit jne. järjestetään aakkosjärjestykseen.

HelloWorld at every new panel[muokkaa | muokkaa wikitekstiä]

Jokainen usi välilehti sisältää valmiin "Hello World" -ohjelmarungon. Tämä on tarkoitettu ensikertalaisille, ja muut voivat kytkeä sen pois päältä.

Make commands hyperlinks to help[muokkaa | muokkaa wikitekstiä]

Kun siirrät hiirikursorin avainsanan päälle, siihen tulee linkin tapainen alleviivaus. Voit tämän jälkeen tuplaklikkaamalla avata kyseisen komennon oppaan - jos s on saatavilla.

Font[muokkaa | muokkaa wikitekstiä]

Tästä voit muuttaa editorin kirjasinta ja sen kokoa.

Tab length[muokkaa | muokkaa wikitekstiä]

Muuttaa tabulaattorin eli sarkaimen pituutta. Vakioituneita arvoja ovat 2 tai 4. Mitä suurempi sisennys, sitä selvempää koodi on.

Flatten BackColor[muokkaa | muokkaa wikitekstiä]

Kopioi normaalin tekstin taustavärin muihin kohteisiin, kuten avainsanoihin, kommentteihin ja numeroihin.

Voit palauttaa oletusasetukset klikkaamalla Defaults-painiketta.

Käännösasetukset[muokkaa | muokkaa wikitekstiä]

Kaikki kääntäjän asetukset löytyvät Project-valikosta. Sieltä voit asettaa jokaiselle lähdekoodille erikseen komentorivin ja Force Variable Declarationin. Jälkimmäinen pakottaa esittelemään kaikki muuttujat ennen niiden käyttöä Global- tai Dim-avainsanoilla.

Väriteemat[muokkaa | muokkaa wikitekstiä]

Löytyvät niin ikään editorin asetusikkunasta (kts. ylempää). Edusväriä (tekstiä) muutetaan Fore-painikkeella, ja taustaväriä Back-painikkeella. Ilmestyvästä värivalintalaatikosta valitaan uusi väri, ja hyväkytään OK. Asetukset tulevat voimaan, kun hyväksyt kaikki valinnat koko asetusikkunan OK-painikkeella. Värit tallennetaan kun CoolBasic suljetaan.