GIMP/Tulosta

Kohteesta Wikikirjasto
Siirry navigaatioon Siirry hakuun
GIMP Icon.svg

Tämä on Wikikirjaston GIMP-kirjan (https://fi.wikibooks.org/wiki/GIMP) tulostettava versio.

GIMP on avoimeen lähdekoodiin perustuva ilmainen kuvankäsittelyohjelma. Ohjeiden pitäisi lähteä niin perusteista, että ne ovat ymmärrettävissä ilman aiempaa kuvankäsittelykokemusta, mutta lukijan täytyy huomata, että kokeneemmat kirjoittajat saattavat pitää monimutkaisiakin välivaiheita yksinkertaisina ja jättää ne merkitsemättä.

Monet Gimpin toiminnoista ovat valikoissa. Valikkokomennot merkitään usein teksit lyhentämiseksi muotoon "Tiedosto / avaa" tai "Tiedosto -> avaa", joka tarkoittaa Tiedosto-valikosta löytyvää avaa-komentoa.

Hyödyllisiä linkkejä:


Sisällysluettelo

GIMPin käytön aloittaminen[muokkaa]

Asennus[muokkaa]

GIMPin voi asentaa Linux-, Windows- ja macOS-käyttöjärjestelmiin. Gimpin viralliselta sivustolta löydät aina ohjelman uusimmat versiot. Useimmille Linux-jakeluversioille on omat asennuspakettinsa, jotka löytää useimmiten jakelun omista pakettivarastoista ohjelmien asentamiseen tarkoitetun pakettienhallintaohjelman avulla.

GIMPin asentaminen Windowsiin[muokkaa]

GIMP toimii vain Windows 7 -käyttöjärjestelmällä tai uudemmalla.

  1. Lataa uusin versio GIMPistä osoitteesta www.gimp.org/downloads
  2. Avaa .exe-asennustiedosto
  3. Napauta pari kertaa Next, kunnes saat kuvan kaksi mukaisen ikkunan.
    • Jos haluat päästä käyttämään GIMPiä mahdollisimman nopeasti, valitse Install ja loikkaa kohtaan 10.
    • Jos haluat päättää minne GIMP asennetaan ja muuta edistyneempää, paina Customize.
  4. Valitse asennuskansio (esim. C:\Program Files\GIMP)
  5. Valitse haluamasi asennustiedostot, ei ole pakko muuttaa.
  6. Seuraavasta ikkunasta valitaan, mitkä tiedostotyypit asetetaan avattavaksi GIMPillä. Oletuksena GIMPillä avataan vain GIMPin omat tiedostomuodot kuten XCF-kuvat ja GIMP-sivellintiedostot. Voit ruksia luettelosta haluamasi.
    • Vinkki: Älä valitse mitään. Esim. Windows XP avaa silloin kaksoisklikkauksella kuvat kuvien ja faxin esikatseluohjelmalla eikä GIMPillä. XP:n oma esikatseluohjelma aukeaa paljon GIMPiä nopeammin.
  7. Valitse millä nimellä GIMP näkyy Käynnistä-valikossa ja paina Next.
  8. Valitse luodaanko GIMP-kuvakkeet työpöydälle/käynnistä-valikon "etusivulle". Nämä kuvakkeet voi myös lisätä jälkikäteen. Paina Next.
  9. Tämän jälkeen näytetään yhteenveto tulevasta asennuksesta. Mikäli kaikki on niin kuin haluat, paina Install.
  10. Asennuksen onnistuttua paina Finish ja nauti uudesta GIMPistäsi.

GIMPin asentaminen Ubuntuun[muokkaa]

Tämä ohje neuvoo GIMPin asentamisen Ubuntun versioon 10.04 (koodinimeltään Lucid Lynx). Tätä aiemmat versiot käyttävät erilaista, "Lisää/poista sovellus"-nimistä työkalua ohjelmien asentamiseen, mutta senkin avulla ohjelmien asentaminen on helppoa ja suoraviivaista.

  1. Käynnistä "Ubuntun sovellusvalikoima" -ohjelma Sovellukset-valikosta.
  2. Ohjelman käynnistyttyä näet ikkunan oikeassa yläkulmassa hakupalkin; sen tunnistaa pienestä suurennuslasikuvakkeesta. Kirjoita hakupalkkiin "GIMP" tai "gimp", kirjainkoolla ei ole väliä. Ensimmäisenä hakutuloksena näkyy "GIMP-kuvankäsittely".
  3. Valitse hakutuloksista GIMP-kuvankäsittely ja napsauta Asenna-painiketta. Tällöin sinua pyydetään tunnistautumaan salasanan avulla. Syötä tunnistautumiskenttään kirjatumissalasanasi ja paina "Tunnistaudu".
  4. Odota kun GIMP ladataan pakettivarastoista ja asennetaan. Asennuksen valmistuttua GIMP löytyy Sovellukset-valikon Grafiikka-alavalikosta.

Ensimmäinen käynnistyskerta[muokkaa]

Kun GIMP käynnistyy ensimmäistä kertaa, ohjelma kyselee erilaisia asetuksia ja hakemistopolkuja. Jos termit tuntuvat vierailta, näistä ei tarvitse välittää vaan klikkaa sinnikkäästi "Jatka"-nappulaa. Ensimmäisellä kerralla ohjelman käynnistyminen kestää suhteellisen kauan, mutta se on normaalia.

Paneelit[muokkaa]

GIMP-paneelit-uusittu.png

Ensimmäiseksi kannattaa asetella paneelit (tai ikkunat) haluamallaan tavalla. Eräs hyväksi havaittu konsti on laittaa yhteen ikkunaan haluamansa paneelit ja avata kuva aina toiseen ikkunaan. Itselläni on toisessa paneelissa auki aina Työkalujen asetukset, Tasot, Polut, Kanavat ja Toimintohistoria. Näitä tietysti kannattaa säätää omien mieltymystensä mukaiseksi. Paneeleja voit yhdistää samaan ikkunaan yksinkertaisesti avaamalla haluamasi paneelit Ikkunat-valikosta ja raahaamalla paneelin otsikkorivin jo auki olevan paneelin otsikkoriville, jolloin paneelit siirtyvät eri välilehtiin. Jos haluat pitää useampaa paneelia samanaikaisesti auki samassa ikkunassa, raahaa paneelin otsikkorivi valmiin ikkunan kapeaan harmaaseen kohtaan (kuvassa oleva musta nuoli).

Asetukset[muokkaa]

Kannattaa tutustua ohjelman asetuksiin ennen käytön aloittamista. Asetukset löytyvät Gimpin pääikkunasta valikosta Tiedosto/asetukset. Voit tehostaa toimintaasi huomattavasti mm. määrittelemällä sopivat näppäimistöoikopolut.

Kuvan avaaminen[muokkaa]

Kuvan avaaminen gimpissä.jpg

Voit avata kuvan monella tavalla GIMPin pääikkunasta.

Vaihtoehtoina ovat:

  • Uusi - avaa uuden kuvan. Voit valita kuvan koon ja pohjan värin tai läpinäkyvyyden.
  • Avaa - avaa tiedosto omalta koneeltasi
  • Avaa sijainti - avaa kuvan verkkosijainnista
  • Pikavalinnat - avaa viimeksi käsitellyistä tiedostoista
  • Kuvan syöttö - avaa kuvan a)leikepöydältä (liitä uutena, leikepöydältä) b)kuvankaappaustoiminnolla voit kaapata kuvan näytöltä
  • TWAIN - voit tuoda kuvan TWAIN-ajurin avulla esim. kuvanlukijasta tai kamerasta.

Jos menet kuvaikkunan tiedosto-valikkoon, löydät edellämainittujen lisäksi "Avaa tasona" -kohdan, joka tuo avattavan kuvan uudeksi tasoksi muokattavaan kuvaan.

Kuvan muokkaamisen aloittaminen[muokkaa]

Jos aiot muokata kuvaa rankemmin (siis tehdä jotain, jonka onnistuminen ei ole varmaa), kannattaa aloittaa tallentamalla se toiseen kansioon .xcf-tyyppisenä. Tällöin et vahingossakaan tallenna puolivalmista työtä alkuperäisen päälle. Tämä GIMPin oma formaatti säilyttää myös kuvaan mahdollisesti lisätyt tasot, vektorit ja tekstit. Voit siis muokata myös kirjoittamiasi tekstejä jälkikäteen.

Tallentaminen[muokkaa]

Tiedostomuoto kannattaa valita käyttötarkoituksen mukaan. Jollet valitse tiedostotyyppiä, GIMP ei suostu tallentamaan. Huomaa, että pääte täytyy kirjoittaa itse tallenna nimellä -ikkunaan. Toinen vaihtoehto on klikata Tiedoston tyyppi (nimen loppuliitteen mukaan).

  • .xcf on GIMPin oma tiedostomuoto jota kannattaa käyttää mikäli aiot muokata kuvaa myöhemmin. Jos haluat laittaa kuvan puolivalmiina levitykseen, tallenna se myös toisella tiedostomuodolla — ethän tiedä onko kuvan käyttäjällä GIMP asennettuna. Tämä tiedostomuoto säilyttää tasot ja kaikki GIMPillä tehdyt muokkaukset. Jos kuvassa on paljon tasoja (engl. layers), tiedostokoko on suuri. Voit pakata tällaisen tiedoston lisäämällä tiedostopäätteen perään .gz tai .bz2 (esim. omakuva.xcf.gz). Gimp osaa avata tällaiset pakatut tiedostot, mutta muut ohjelmat eivät välttämättä osaa.
  • .psd on Adobe Photoshopin (varsinkin ammattilaisten keskuudessa suosittu ohjelma) kanssa yhteensopiva ja se säilyttää tasot. Mitä enemmän tasoja kuvassa on, sitä suurempi on tiedoston koko.
  • .jpg on hyvä esimerkiksi valokuvien tallentamiseen, kun kuva on muokattu valmiiksi. Tämä tiedostomuoto pakkaa kuvaa ja laatu heikkenee. Jos haluat säilyttää laadun mahdollisimman hyvänä, valitse laaduksi 100.
  • .png sopii kaavioihin ja logoihin. Tämä tiedostomuoto pakkaa kuvaa, muttei heikennä kuvan laatua. Huomaa, että kaikki selaimet (lue: Internet Explorerin vanhat versiot) eivät tue png-kuvien läpinäkyvyyttä, joten vältä läpinäkyvyyden käyttämistä nettisivuilla, kun sivujen oikea näkyminen on tärkeää.
  • .gif sopii kaavioihin ja logoihin. Huomaa, että .gif-muodossa on rajoitettu värimäärä, enintään 256. Tiedostomuoto tukee läpinäkyvyyttä ja animaatiota.

GIMPin perusteet[muokkaa]

Tällä sivulla käsitellään GIMPin perusominaisuudet, työkalut ja valikoiden sisällöt.

Työkalut[muokkaa]

Gimp-tyokalut.jpg

Valintatyökalut[muokkaa]

Työkaluryhmän numero 1

Valintatyökaluja ovat:

  • suorakulmainen valinta R
  • ellipsivalinta E
  • Vapaavalinta (lasso) F
  • Sumea valinta (taikasauva) - väriltään yhtenäiset alueet U
  • Valitse värillä- valitsee samanvärisen yhtenäisen alueen Vaihto+O
  • Saksivalinta I
  • Edustan valinta

Kun käytät suorakulmaista- tai ellipsivalintaa, voit shift-, ctrl- ja alt-näppäimiä käyttämällä muuntaa valinnan käyttäytymistä.

  • Jos painat pohjaan ennen valinnan aloittamista:
    • Shift - voit valita lisää.
    • Ctrl - voit vähentää valintaa.
    • Shift & Ctrl - vanhan ja uuden valinnan päällekäin menevät osat valitaan.
  • Jos painat pohjaan valintaprosessin alettua:
    • Shift - tekee valinnasta yhtä korkean kuin leveän (neliön tai ympyrän).
    • Ctrl - aloituspisteestä tulee valinnan keskipiste.
    • Alt - voit siirtää valintaa.

Polkutyökalu[muokkaa]

Työkalun pikavalinta B, työkaluryhmän numero 2

Polkutyökalulla voit luoda ja muokata polkuja. Työkalu on erittäin tehokas kun tehdään valintoja, joissa on runsaasti suoria tai likipitäen säännönmuokaisesti kaareutuvia pintoja. Polut tallentuvat .xcf-muodossa tallennettujen töiden mukana.


Värinpoiminta[muokkaa]

Työkalun pikavalinta O, työkaluryhmän numero 3

Värin poimintatyökalulla voit valita kuvasta tietyn värin. Painamalla Ctrl-näppäimen pohjaan ennen kuin valitset värin voit valita ns. taustavärin. Muuten valinta kohdistuu ns. etuväriin eli piirtoväriin.


Zoom[muokkaa]

Työkalun pikavalinta Z, työkaluryhmän numero 4

Zoomaustyökalulla pystyt zoomaamaan lähemmäs ja kauemmas painamalla kuvaa. Ctrl-näppäimellä voit vaihtaa zoomataanko lähemmäs vai kauemmas. Vetämällä valinnan voi valita alueen mihin zoomataan.

Mittatyökalu[muokkaa]

Työkalun pikavalinta Vaihto+M, työkaluryhmän numero 5

Mittatyökalu näyttää pisteiden välisen etäisyyden ja kulman. Mittausta varten valitse työkalu, klikkaa ensimmäistä pistettä ja raahaa kohdistin hiiren nappi pohjassa toiseen pisteeseen. Etäisyys ja kulma näkyvät tilarivillä. Ctrl pohjassa kulma muuttuu 15° välein.

Siirtotyökalu[muokkaa]

Työkalun pikavalinta M, työkaluryhmän numero 6

Siirtotyökalulla voit siirtää tasoja tai valittuja alueita.

Kohdistustyökalu[muokkaa]

Työkalun pikavalinta Q, työkaluryhmän numero 7

Kohdistustyökalulla voit kohdistaa ja järjestää tasoja tai muista kohteita

Rajaa & muuta kokoa[muokkaa]

Työkalun pikavalinta Vaihto+C, työkaluryhmän numero 8

Rajaustyökalulla voit pienentää kuvan kokoa ja poistaa ei valitun osan kuvasta. Koon muuttaminen pienentää kuvaa poistaen valitsemattoman alueen.

Muunnostyökalut[muokkaa]

Työkaluryhmän numero 9

Muunnostyökaluja ovat:

  • kierto Vaihto+R
  • skaalaus Vaihto+T
  • vääntö Vaihto+P
  • perspektiivi Vaihto+F

Peilikuva[muokkaa]

Työkalun pikavalinta Vaihto+F, työkaluryhmän numero 10

Peilityökalu kääntää tason tai valinnan peilikuvaksi. Ctrl-näppäin vaihtaa peilikuva suunnan horisontaalinen ja vertikaalinen vaihtoehtojen välillä.

Tekstityökalu[muokkaa]

Työkaluryhmän numero T

Tekstityökalua käytetään kirjoitettaessa tekstiä kuviin. GIMPin versiosta 2.0 eteenpäin tekstit ovat olleet muokattavissa jälkikäteen. Klikkaa kuvaa tekstityökalulla ja kirjoita haluamasi teksti aukeavaan tekstieditoriin. Tekstin paikkaa voit muuttaa jälkikäteen siirtotyökalulla raahaamalla hiirellä kirjaimen kohdalta. Fonttia ja tekstin väriä voit muuttaa työkalun asetuksista.

Klikkaamalla tasopaneelista tekstitasoa oikealla hiirennäppäimellä saat eteesi valikon:

  • Tekstityökalun avulla voit korjata kirjoittamaasi tekstiä
  • Yhdistä alas liittää tekstin ensimmäiseen tekstitason alapuolella olevaan näkyvään tasoon. Tämän jälkeen et voi enää korjata kirjoitusvirheitä.
  • Hylkää tekstidata muuttaa tekstitason tavalliseksi, läpinäkyväksi, tasoksi, jossa teksti näkyy kuin mikä tahansa kuva. Valinnan käytön jälkeen tekstiä ei enää voi muokata.

Täyttötyökalu[muokkaa]

Työkalun pikavalinta Vaihto+B, työkaluryhmän numero 12

Täyttötyökalu alueen värillä tai kuviolla. Asetuksista valitaan täytetäänkö koko valinta vai alue, jonka pikselien värit ovat riittävän lähellä toisiaan. "Raja"-liukusäätimellä voidaan vaikuttaa siihen, kuinka samanvärisiä pikselien täytyy olla, jotta ne väritetään.

Väriliukuma[muokkaa]

Työkalun pikavalinta L, työkaluryhmän numero 13

Väriliukuma täyttää alueen väriliukumalla.

Piirtotyökalut[muokkaa]

Piirtääksesi suoran viivan millä tahansa työkalulla valitse aloituspiste ja pidä Shift-näppäin painettuna pohjaan.

Työkaluryhmän numero 14
  • Kynä - Piirtää teräväreunaisia viivoja. N
  • Sivellin - Piirtää pehmeäreunaisia viivoja. P
  • Kumi - Pyyhkii kuvaa korvaten poistetun osan taustavärillä. Vaihto+E
  • Ruiskutyökalu - Piirtää viivoja. painetta ja värin määrää voi säätää. A
  • Mustekynä - Piirtää vaihtelevia viivoja. K
  • Kloonaustyökalu - Maalaa käyttäen kuviota tai kuvan osia. Ctrl-näppäimellä voit määritellä kuvan osan. C
  • Sumennus- ja tarkennustyökalu Vaihto+U
  • Tuhrintatyökalu - Toimii kuten nihkeä sormi hiili- tai lyijykynätyössä. S
  • Varjostus ja Lisävaloitus Vaihto+D

Valikot[muokkaa]

Pääikkunan valikot[muokkaa]

Tiedosto[muokkaa]

  • Uusi - avaa uuden kuvan. Voit valita kuvan koon ja pohjan värin tai läpinäkyvyyden.
  • Avaa - avaa tiedosto omalta koneeltasi
  • Avaa sijainti - avaa kuvan verkkosijainnista
  • Pikavalinnat - avaa viimeksi käsitellyistä tiedostoista
  • Kuvan syöttö - avaa kuvan a)leikepöydältä (liitä uutena, leikepöydältä b)kuvan kaappaus toiminnolla voit kaapata kuvan näytöltä
  • TWAIN - voit tuoda kuvan TWAIN ajurin avulla esim. skannerista tai kamerasta.

  • Asetukset - voit muuttaa ohjelman asetuksia
  • Ikkunat - Voit avata erilaisia paneeleja,. Valikon sisältö on sama, kuin kuvaikkunan Ikkunat-valikossa.

Poistu - Sammuttaa GIMPin

Laajennokset[muokkaa]

  • Modulinhallinta –Voit määrittää mitkä modulit ladataan käynnistymisen yhteydessä tai ladata modulin.
  • Liitännäisselain –Näet mitä liitännäisiä (plugin) on asennettuna.
  • Proseduuriselain – Näet mitä proseduureja on asennettuna.
  • Yksikköeditori –Voit muokata yksikköjä ja ottaa käyttöön uusia yksiköitä.
  • Script-fu – Sisältää monia hyödyllisiä ja helppokäyttöisiä scriptejä (komentojonoja), joilla voit helposti tehdä esimerkiksi webgrafiikkaa.
  • Split Video into Frames–erottaa videosta yksittäisen ruudun.

Ohje[muokkaa]

  • Ohje (F1) –Aukaisee ohjeen. Huom! ohje täytyy olla asennettuna (katso Gimp/Aluksi).
  • Yhteydestä riippuva avustus (Vaihto+F1) –Näyttää hiirtä klikkaamalla yhteyteen sopivan ohjeen.
  • Päivän vihje –Vihjeet, joista on hyötyä, englanninkielinen.
  • Tietoja –Näyttää käytettävän gimpin version.
  • Gimp verkossa –Linkit gimpin virallisiin verkkosivuihin.

Kuvaikkunan valikot[muokkaa]

Tiedosto[muokkaa]

  • Uusi - luo uuden kuvan
  • Avaa - Avaa jo tehdyn kuvan
  • Avaa tasona - Vanha kuva liitetään tasoksi aktiiviseen kuvaan (voit yhdistää useita kuvatiedostoja yhdeksi kuvaksi)
  • Avaa sijainti - Voit avata kuvan, joka on Internetissä tai jonka hakemistopolun tiedät.
  • Pikavalinta - Viimeksi avattuja kuvia

  • Tallenna - Tallentaa vanhan tiedoston päälle, mikäli kuva on vasta luotu GIMP käyttää automaattisesti valintaa "Tallenna nimellä"
  • Tallenna nimellä - Tallenna kuvatiedosto uudella nimellä ja muokkaa tiedostoa sen uudella nimellä
  • Tallenna kopio - Tallenna uudella nimellä, mutta jatka vanhannimisen tiedoston muokkaamista
  • Tallenna malliksi
  • Palauta - Palauttaa käsiteltävän tiedoston viimeiseen tallennukseen (Vastaa komentoa Avaa+tiedostonNimi)
  • Palauta

  • Sivun asetukset - tulostusasetuksia (esim onko paperi vaaka vai pystysuunnassa)
  • Tulosta - Tulostaa kuvan

  • Sulje - Sulkee käsiteltävän kuvan
  • Poistu - Sulkee koko GIMPin

Muokkaa[muokkaa]

Gimpin muokkaa valikko on monipuolinen ja on jaettu neljään osaan, joista ensimmäinen liittyy tehtyjen toimintojen kumoamiseen ja uudelleen suorittamiseen. Toisen osa liittyvät kopioimiseen ja liittämiseen. Kolmas osa liittyy piirtoalueen täyttämiseen ja tyhjentämiseen. Neljäs osa on kopiointi leikepöydälle ja leikepöydältä.

Muokkaa valikon toimintoja käytetään yleensä valintatyökalujen kanssa. Jos et käytä valintaa, toiminto kohdistuu koko alueeseen (kuvatasoon). Kannattaa opetella työskentelemään näppäimistön kautta, koska se vapauttaa hiiren piirtämiseen.

  • Kumoa (Ctrl+Z) –Voit kumota tekemäsi toiminnon.
  • Uudelleen (Ctrl+Y) –Voit tehdä toiminnon uudelleen.
  • Toimintohistoria –Avaa toimintohistoria ikkunan, josta voit selata tekemisiäsi toimintoja ja poistaa niitä.

  • Leikkaa (Ctrl+X) –leikkaa valitun alueen leikepöydälle.
  • Kopioi (Ctrl+C) –kopioi valitun alueen leikepöydälle.
  • Liitä (Ctrl+V) –liittää leikepöydältä kuvaan.
  • Liitä johonkin –liittää leikepöydältä kuvan valintatyökalulla rajattuun osaan.
  • Liitä uutena –liittää kuvan leikepöydältä uudeksi kuvaksi.
  • Leike –voit nimetä kopioidun leikkeen leikepöydälle ja poimia sen nimetyn leikkeen.

  • Tyhjennä –tyhjentää piirtoalueen tai valitun alueen.
  • Täytä edustavärillä –täyttää piirtoalueen tai valitun alueen edustavärillä.
  • Täytä taustavärillä –täyttää piirtoalueen tai valitun alueen taustavärillä.
  • Täytä kuviolla –tyhjentää piirtoalueen tai valitun alueen kuviolla.
  • Piirrä valinta –voit piirtää valinnan siveltimellä.
  • Piirrä polkua pitkin –voit piirtää valinnan polkutyökalulla.

  • Kopioi leikepöydälle –kopioi leikepöydälle.
  • Liitä leikepöydältä –liittää leikepöydältä.

Valitse[muokkaa]

Tästä valikosta löytyviä toimintoja käytetään valintojen hallitsemiseen.

  • Kaikki - valitsee koko kuvan.
  • Ei mikään -toiminnon jälkeen mitään ei ole valittuna.
  • Käänteinen - Valituista osista tulee valitsemattomia ja päinvastoin.
  • Kelluva -komennon käytön jälkeen valittuna ollut osa muuttuu kelluvaksi valinnaksi, eli valittua osaa voi siirtää kuvan toiselle alueelle. Kelluva valinta ankkuroidaan alla olevaan tasoon klikkaamalla valittua aluetta hiirellä, kun kursorin yllä on ankkuri tai tasot-paneelista.
  • Värin mukaan - Kuvapisteet, joiden värisävy on riittävän lähellä klikattua pistettä tulevat valituiksi. Valittu alue ei välttämättä ole yhtenäinen, kuten Valitse väriltään yhtenäisiä alueita -työkalun tekemä valinta.
  • Polusta - toiminto muuttaa aktiivisena olevan polun valinnaksi
  • Valintaeditoria voidaan käyttää mm. valinnan tallentamiseen.

  • Pyöristä häivyttää valintaa hitaasti jyrkän päättymisen sijasta. Erittäin käyttökelpoinen ominaisuus. Jos valitset pyöristä 10px, tulee osittain valittu alue 5px alkuperäisen valinnan reunoista molempiin suuntiin.
  • Terävöitä - Kumoa pyöristä-komennon vaikutus
  • Pienennä - pienentää valintaa
  • Laajenna -laajentaa valintaa
  • Reuna - Valitsee vain valinnan reuna-alueet teityllä etäisyydellä valinnan alkuperäisistä rajoista.
  • Pyöristetty neliö -häivyttää kulmat valinnasta
  • Aseta QMask- kts. QMaskin ohjeet.
  • Tallenna kanavalle / poluksi - Tallentaa tiedon valituista alueista myöhempää käyttöä tai muokkausta varten.

Näytä[muokkaa]

  • Uusi näkymä valinta avaa saman kuvan toiseen ikkunaan. Esimerkiksi toisessa ikkunassa voi näkyä koko kuva, kun taas toinessa ikkunassa muokkaat yksityiskohtaa. Muutokset näkyvät molemmissa kuvissa.
  • Piste pisteeltä
  • Suurenna xxx% - Erilaisia zoomausvaihtoehtoja

  • Pienennä ikkuna pienentää ikkunan kuvan kokoiseksi (mikäli kuva on ikkunaa pienempi)
  • Kokoruutu - Avaa kuvan koko ruudun kokoiseksi

  • Infoikkuna antaa tietoja kuvatiedostosta ja hiiren kursorin paikasta
  • Navigointi avaa erillisen navigointi-ikkunan, josta voi hallita näytettävää aluetta ja zoomausta.
  • Näyttösuotimet sisältävät näytöllä näkyvään kuvaan vaikuttavia suotimia (leluja?)

  • Näytä valinta Piiloittaa tai näyttää valitun alueen rajat katkoviivalla. Hyödyllinen muokattaessa valintaa.
  • Näytä tason rajat - Tasot voivat olla eri kokoisia
  • Näytä apulinjat - Apuviivoja voit asettaa Kuva-valikosta
  • Naksahda apulinjoihin - Työkalut kulkevat apuviivoja pitkin, mikäli kursori menee tarpeeksi lähelle viivaa.
  • Näytä apuviivat ja Naksahda apuviivoihin - vastaavat apulinjoja
  • Oma laajennosväri

  • Näytä menupalkki - Voit kytkeä menupalkin pois päältä (Menupalkissa ovat valikot, poiskytkemisen jälkeen pääset valikoihin klikkaamalla kuvaa hiiren oikealla näppäimellä)
  • Näytä viivoittimet - Voit piiloittaa tai ottaa käyttöön näytön sivulla olevat mittatikut
  • Näytä vierityspalkit - Voit piiloittaa tai ottaa käyttöön näytön sivulla olevat vierityspalkit. Jos palkit eivät ole näkyvissä, voit valita kuvan näytettävän osan raahaamalla hiiren kolmospainikkeella tai avaamalla Navigointi-ikkunan (Näytä-valikosta).
  • Näytä tilapalkki - Piiloittaa kuvaikkunan alareunan tietopalkin.

Kuva[muokkaa]

  • Kahdenna - Avaa aktiivisen kuvan toiseen ikkunaan uudella nimellä. Voit esimerkiksi kahdentaa kuvan ennen muokkauksen aloittamista, jolloin muokkaukset eivät muuta alkuperäistä tiedostoa
  • Tila - Voit säätää miten värit esitetään.
    • RBG
    • Harmaasävy
    • Indeksoitu
    • Hajoita
    • Yhdistetään
  • Muunnos - Kuvan peilaaminen ja kääntäminen

  • Kankaan koko - Voit muuttaa kuvan kokoa siten, että osa kuvasta rajautuu pois tai kuvan reunoille tulee "tyhjää" tilaa.
  • Sovita kangas tasoihin - Kuvaa laajennetaan (tai pienennetään) siten, että kaikki tasot mahtuvat kokonaan kuvaan.
  • Tulostuskoko
  • Skaalaa kuvaa - Muuta kuvan kokoa. Kts. Ohje
  • Rajaa kuva - Rajaa kuvan valinnan reunan kohdalta. Mikäli valinta ei ole suorakaide, rajataan siten, että koko valinta mahtuu uuteen kuvaan.
Vasemmalta oikealle:Alkuperäinen kuva, Automaattisesti rajattu kuva ja Zealous Cropilla rajattu kuva
  • Kuvan automaattinen rajaus - Etsii kuvan reunuksen ja rajaa sen pois. Jos esimerkiksi kuvan reunalla on yksivärinen kehys, poistetaan se. Huomaa, että toiminto rajaa kaikki tasot, mutta tutkii vain aktiivista tasoa, mikä voi johtaa kuvadatan menetykseen. Katso myös oheinen kuva.
  • Zealous Crop - Kuten automaattinen rajaus, mutta poistaa yksivärisiä osioita myös kuvan keskeltä.

  • Yhdistä näkyvät tasot - Yhdistää vain näkyvissä olevat tasot (Tasot-paneelissa tason vieressä on silmäkuvake).
  • Yhdistä kuva - Yhdistää kaikki tasot.

  • Apulinjat - Toiminnolla voi luoda ja poistaa vaaka- tai pystysuoria apulinjoja.

Taso[muokkaa]

  • Uusi taso - Luo uuden tason vanhan päälle. Tason täyttötavaksi voi valita edustavärin, taustavärin, valkoisen tai läpinäkyvyyden.
  • Kahdenna taso - Luo vanhan tason päälle kopion siitä.
  • Poista taso - Poistaa tason.
  • Pino - Voi valita tiettyjä tasoja, jos niitä on monta päällekkäin.
  • Värit - Mahdollisuus säätää mm. väritasapainoa, sävy-värikylläisyyttä ja kontrastia.
  • Suotimet -

Työkalut[muokkaa]

Ikkunat[muokkaa]

Suotimet[muokkaa]

Script-Fu[muokkaa]

Script-Fu sisältää valmiita komentosarjoja, jolla voi helposti ja nopeasti muokata kuvaa, vaikka ei edes olisi kokemusta kuvankäsittelystä. Script-Fu toiminnot löytyvät Gimpin valikosta. Niitä käyttämällä voi esimerkiksi helposti, yhdellä klikkauksella, häivyttää kuvasta reunat tai tehdä siitä vanhan valokuvan näköisen.

Video[muokkaa]

HUOM! Tämä valikko on käytössä, kun olet asentanut gap(animaatio) paketin.

Perusominaisuudet[muokkaa]

Tasot[muokkaa]

Gimp-tasot.png

Tasoja (engl. Layer) voi ajatella ikäänkuin piirtoheitinkalvoina: osa tasosta voi olla läpinäkyvä, jolloin alapuolella oleva taso näkyy läpi. Tasot ovat erittäin tehokkaita työskentelyn apuvälineitä. Tasojen hallinta sujuu tasopaneelista käsin (kts. kuva). Muutokset koskevat (lähes aina) vain valittua tasoa. Voit esimerkiksi ottaa kuvan, luoda uuden, läpinäkyvän tason kuvan yläpuolelle ja töherrellä tähän vastaluotuun tasoon. Lopuksi voit poistaa tason ja alkuperäinen kuva on koskematon. Tasojen näppärää käsittelyä varten kannattaa pitää auki tasot-ikkunaa (kts. viereinen kuva). Ikkunassa näkyy missä järjestyksessä tasot ovat, ylempi peittää alemman, ja siitä saa helposti käyttöön halutut toiminnot.

Tason asetukset[muokkaa]

  • Peitto — Tekee tasosta läpikuultavan
  • Säilytä läpinäkyvyys (Harmaa ruudukko) — Sallii tason muokkaamisen vain jo ennestään väritetyiltä osin.

Uuden tason luominen[muokkaa]

  • Klikkaa tyhjän sivun kuvaa tasopaneelin alareunassa.
  • Uuden tason koko on oletuksena koko kuvan kokoinen.
  • Taso kannattaa nimetä kuvaavasti, ainakin jos teet suurempaa projektia.

Tason poistaminen[muokkaa]

  • Raahaa poistettava taso tasopaneelin alareunassa olevaan roskakoriin.

Tason kahdennus[muokkaa]

Tason kahdennus luo tasosta kopion, joka sijoitetaan kopioitavan tason yläpuolelle. Tasojen kahdennusta voi käyttää esimerkiksi kun tekee muutokset tason kopioon on myöhemmin helppo vertailla lopputulosta alkuperäisen kuvan kanssa. Tasot toimivat myös nopeana tapana palauttaa tilanne jos jokin epäonnistuu.

  • Jos "tasot"-ikkuna ei ole avattuna avaa se valitsemalla ikkunat / tasot.
  • kaksoisklikkaamalla "Tausta"-tasoa avautuu valikko, josta saat tason kahdennettua.
  • Valitse lopuksi uusi taso ja varmista, että sen vieressä näkyy silmän kuva (eli taso näytetään.)

Tason maski[muokkaa]

Tason maskin avulla voidaan helposti määritellä mitkä osat tasosta ovat näkyvillä.

  • Taso / Tason maski / Lisää tason maski
  • Piirrä tavallisilla piirtotyökaluilla, musta väri vastaa läpinäkyvää, valkoinen läpinäkymätöntä ja eri harmaan sävyt läpinäkyvyyden asteita
  • Voit käyttää värittämiseen eri siveltimiä, liukuvärjäystyökalua, tai väritystyökalua.
  • X:ää napauttamalla voit vaihtaa edusta ja taustavärit keskenään. Tällöin voit vuorotellen poistaa ja lisätä tason läpinäkyviä osia.

Polkutyökalu[muokkaa]

Polkutyökalulla luodaan polkuja (engl:Bezier Path), jotka ovat ikäänkuin tallennettuja hiiren liikkeitä. Polkutyökalut ovat omiaan mm. tehtäessä valintaa alueesta, jonka reunat ainakin suurimmaksi osaksi ovat suoria tai likipitäen säännönmukaisia kaaria. Polkutyökaulua käytetään monesti esimerkiksi epätarkkojen logojen muuttamiseen tarkoiksi. Tässä tapauksessa polkutyökalulla piirretään kuvan päälle.

Polkujen luominen[muokkaa]

Polku koostuu kulmista eli ankkureista, jotka ovat yhdistetty toisiinsa käyrillä. Luodaksesi polun valitse polkutyökalu. Klikkaamalla kuvaa saat asetettua uusia kulmia. Kun käyrä on valmis voit yhdistää polun alun ja lopun toisiinsa painamalla Ctrl ja klikkaamalla ensimmäistä ankkuria (Kursorin oikeassa yläkulmassa on ylösalainen U (=magneetti?)). Huomaa, että polkua ei ole pakko sulkea.

Ankkureiden hallinta[muokkaa]

Yksinkertaisimmillaan yhtä ankkuria siirretään raahaamalla se haluttuun paikkaan. Käyttämällä Shiftiä voidaan valita useita ankkureita, joita siirretään kerralla. Koko polkua voit siirtää painamalla Alt-näppäintä. Kulman voit poistaa painamalla pohjaan Ctrl ja Shift näppäimet tai valitsemalla halutun kulman ja painamalla Delete.

Kahvojen hallinta[muokkaa]

Yksinkertainen polku

Kasa toisiinsa suorilla viivoilla yhdistettyjä pisteitä ei ole erityisen käytännöllinen, mutta polkujen vahvuus piilee siinä, että voit määrittää mihin suuntaan kulmasta lähtevä käyrä suuntautuu. Pidä Ctrl pohjassa ja vie hiiri kulman päälle. Kun kursori muuttuu sormella osoittavaksi kädeksi paina hiiren nappi pohjaan ja vedä kulmasa ulos kahva (engl: control handle). Jos hiiren kursori ei muutu on luultavasti polkutyökalun asetuksista ruksittu kohta Lisää uusia kulmia. Kahvan suunta kertoo mihin suuntaan käyrä jatkaa matkaansa lähtiessään kulmasta, kahvan pituus kertoo kuinka pitkälle tähän suuntaan on kuljettava ennen kuin käyrä saa jatkaa matkaansa seuraavaa kulmaa kohti. Jokaiseen kulmaan kuuluu kaksi kahvaa (joista osa voi olla kulman kohdalla, jolloin ne eivät vaikuta polun kulkuun.) Liikuttamalla kahvaa Shift pohjassa saman kulman toinen kahva siirtyy ensimmäisen kanssa symmetrisesti. Vain valitun kulman (ympyrästä vain ääriviivat) kahvat ovat näkyvissä. Erityisesti polkutyökalun kanssa on huomattava, että vain harjoitus tekee mestarin.

Polkutyökalun asetukset[muokkaa]

Muokkaustilan arvona voi olla jokin seuraavista:

  • Suunnittele — Käytetään luotaessa polkua ja säädettäessä kahvoja.
  • Tässä tilassa käyrän raahaaminen muuttaa käyrän molemmissa päissä olevien ankkureiden kahvojen tilaa. Shift pohjassa kaikki neljä (kaksi kahvaa kahdessa ankkurissa) kahvaa liikkuvat
  • Muokkaa (Vaihtoehtoisesti pidä Ctrl pohjassa) — Voit lisätä polkuun ankkureita klikkaamalla polkua
  • Siirrä — Siirtää polkua kokonaisuutena, sama vaikutus on jos pitää altin pohjassa ja raahaa polkua.

Valinnan luominen polkutyökalulla[muokkaa]

Valintaa tehdessä kannattaa ankkurit sijoittaa valittavan alueen kulmakohtiin. Ankkureita ei kannata käyttää liikaa, sillä jokainen ankkuri tarkoittaa uusia kahvoja säädettäväksi. Monesti valintaa joutuu hienosäätämään vielä esimerkiksi pikamaskin avulla. Kun polku vastaa mahdollisimman hyvin valittavan osan reunoja komenna Valitse -> polusta tai klikkaa vastaavaa kuvaketta tasot-paneelissa.

Pikamaski[muokkaa]

Pikamaski tai QMask (engl. Quickmask) on tehokas työkalu epäsäännöllisten alueiden valitsemiseen. Pikamaski on parhaimmillaan kun hienosäädetään valintaa, esimerkiksi reunoista, kun ensin on tehty varsinainen valinta.

  • Tee ensin valinta normaaleilla valintatyökaluilla
  • Klikkaa kuvaikkunan vasemmassa alareunassa olevaa katkoviivaneliötä.
  • Valittu osa näkyy normaalisti, valitsematon osa on läpikuultavan punaisen kerroksen alla
  • Nyt voit tarkasti värittää juuri haluamasi kohdat, musta väri pienentää valintaa ja valkoinen kasvattaa.
  • Kun olet valintasi tehnyt klikkaa uudelleen QMask kuvaketta ikkunan alareunassa

Pikamaskin asetukset[muokkaa]

Pikamaskista voi säätää muutamaa näppärää ominaisuutta. Kaikki löytyvät kun klikataan oikealla hiirennäppäimellä QMask -painiketta.

  • Maskaa (eli väritä) valitut alueet / valitsemattomat alueet.
  • Aseta väri ja läpinäkyvyys.

Kelluva valinta[muokkaa]

Kelluva valinta (engl: floating selection / float) kelluva valinta on erikoinen taso, joka luodaan joskus automaattisesti ja jonka voi tarpeen vaatiessa luoda itsekin. Kun kelluva valinta on luotu, ei muita tasoja voi muokata ennen kelluvan valinnan ankkuroimista.

Kelluva valinta luodaan automaattisesti, kun valittuna olevaa kuvan osaa siirretään. Siirto tapahtuu viemällä kursori valinnan sisään ja raahaamalla valintaa. Kyseessä siis ei ole valinnan siirtäminen (alt-näppäin pohjassa). Kelluva valinta luodaan myös kun kuvaan liitetään (muokkaa -> liitä) osioita. Tavallisen valinnan voi muuttaa kelluvaksi komentamalla Valitse -> Kelluva.

Kelluva valinta liitetään alla olevaan tasoon komentamalla taso -> ankkuroi tai menemällä tasot paneeliin ja klikkaamalla hiiren oikealla näppäimellä kelluvaa valintaa ja valitsemalla "Ankkuroi taso". Halutessasi ankkuroida kelluvan valinnan uuteen tasoon komenna Taso -> uusi taso.

Valinnan tallentaminen[muokkaa]

Joskus epäsäännöllisen kappaleen tarkkaan valitsemiseen kuluu runsaasti aikaa ja joskus valinta onnistuu niin hyvin, että sen haluaa tallentaa muuten vain.

  • Valitse / Tallenna kanavalle
  • Kun haluat avata tallennetun valinnan mene Kanavat-ikkunaan ja klikkaa oikealla valintaasi. Valitse Kanava valinnaksi.

Kuvan rajojen muokkaaminen GIMPillä[muokkaa]

Tällä sivulla esitellään tapoja muokata kuvan rajoja ja kokoa.

Kuvan koon muuttaminen[muokkaa]

Joskus, esimerkiksi Internettiin tai sähköpostin liitteenä lähetettävää kuvaa, täytyy pienentää latausaikojen lyhentämiseksi.

  • Avaa kuva ( Tiedosto / avaa )
  • Kuva / Skaalaa kuvaa
  • Tee asetukset
  • "kahle" kahden lukuarvon välillä tarkoittaa sitä, että toisen muuttuessa myös toinen muuttuu samassa suhteessa. Usein tämä on toivottavaa ja se onkin oletuksena päällä. Kahletta klikkaamalla voit ottaa ominaisuuden pois päältä.
  • Interpolaatio kannattaa asettaa kuutiolliseksi, jolloin resoluution pienentämisestä aiheutuvat virheet jäävät mahdollisimman pieniksi.
  • Skaalaa kuvaa

Rajaaminen[muokkaa]

Rajaamisen tärkein "työkalu" on silmä. Tärkein perussääntö sommittelussa on kultainen leikkaus (katso w:Kultainen_leikkaus). Rajaamalla voit pienentää kuvatiedoston kokoa lyhentäen latausaikaa esimerkiksi Internetistä. Voit myös poistaa reunukset tai epäoleelliset asiat kuvasta, jolloin kuvan sisältö aukeaa nopeammin. GIMPissä on myös automaattisia rajaustoimintoja, jotka löytyvät Kuva-valikosta esittelyineen.

  1. Valitse rajaustyökalu ( numero 7 tämän sivun työkaluesittelyssä )Rajaus.jpg
  2. Vedä rajat haluamaasi kohtaan
  3. Klikkaa rajattua aluetta, jolloin kuva rajataan tai sen kokoa muutetaan valinnasta riippuen (kts alla)
  4. Näytölle aukeaa myös uusi ikkuna, josta voit valita rajaamisen ja koon muuttamisen välillä. Voit myös määrittää rajattavat pikselit tarkasti. Suhde-kohta kertoo kuvan leveyden suhteen korkeuteen. Monesti paperille tulostettavien digikuvien suhde on 1,3 ( 13cm : 10 cm ). Jos haluat määrittää kuvasuhteen, näppäile haluamasi suhde ja paina automaattinen pienennys -näppäintä. Tämän jälkeen voit muuttaa kuvan kokoa Shift-näppäimen kanssa kuvasuhteen pysyessä vakiona tai siirtää valintaa raahamalla joko vasemmasta alakulmasta tai oikeasta yläkulmasta
  • Koon muuttaminen muuttaa valitsemattoman osan näkymättömäksi, rajaaminen poistaa sen kokonaan

Työkalun säädöt[muokkaa]

  • Rajaa / muuta kokoa
  • Vain nykyinen taso - Rajaus kohdistuu vain valittuna olevaan tasoon
  • Säilytä kuvasuhde - Kuva pysyy samanmuotoisena suurentamisesta huolimatta

Reunan häivyttäminen kuvasta[muokkaa]

Saari, reuna häivytetty.jpg

Kuvia voi tyylitellä häivyttämällä reunan valkoiseksi (kts. kuva).

  • Valitse ellipsin muotoisella valintatyökalulla kuvan osa, jonka haluat jättää näkyviin. Valitse myös hieman "ylimääräistä" kuvan ympäriltä.
  • Valitse / Pyöristä / pyöristyssäde riippuu kuvan koosta, kokeile aluksi vaikkapa 200 pikseliä.
  • Komento häivyttää valinnan reunan epäteräväksi. Kokeilemalla komennon merkitys tarkentuu.
  • Muuta valintasi käänteiseksi Valinta / Käänteinen komennolla
  • Maalaa nyt valittuna oleva osa valkoiseksi ( tai haluamasi väriseksi ) käyttämällä "maaliämpäriä". Tarkista, että työkalun asetuksista on valittuna "Täytä koko valinta".
  • Lopuksi kannattaa ehkä vielä rajata kokonaan valkoinen osa pois.

Reunan häivyttäminen tyylitellysti[muokkaa]

GIMP, QMask, reunan tyylittely.jpg

Tämä ohje on paranneltu versio edellisestä ohjeesta, mukana QMask toiminnon käyttöä, joten kertaa se aluksi GIMP/Perusteita-osiosta

  • Valitse haluamasi osio, jätä tarpeeksi tilaa reunoille.
  • Käynnistä QMask (kts kuvan teksti ja QMask osio)
  • Suotimet / Vääristykset / Väreily (kts. kuva)
  • Suotimet / Tee epäteräväksi / Tee Gaus sumennus
  • vaihtoehtoisesti voit vaihtaa pikamaskin valinnaksi ja käyttää Valitse / Pyöristä
  • Muuta viimeistään nyt pikamaski valinnaksi ja komenna Valitse / Käänteinen
  • Täytä valittu alue esim. valkoisella käyttämällä maaliämpäriä
  • Voit myös kokeilla muita Suotimet / Vääristykset valikon suotimia erilaisen efektin aikaansaamiseksi.

Hieman monimutkaisempia kuvankäsittelytekniikoita[muokkaa]

Tällä sivulla on hieman monimutkaisempaa kuvankäsittelyä, jota tarvitaan esimerkiksi digikuvia parannettaessa. Tämän sivun ohjeissa oletetaan, että lukija on jo tutustunut GIMPin perusteisiin.

Kuvan kiertäminen[muokkaa]

Kun kuva on alunperin otettu kamera "pystyssä" esimerkiksi kuvattaessa seisovaa ihmistä tai korkeaa rakennusta jää kuvatiedosto "makaamaan" eli kiertyneeksi 90°. Ongelma voidaan korjata komentamalla kuva -> muunnos -> kierrä 90° vasta tai myötäpäivään tapauksesta riippuen.

Digikuvan värien säätäminen[muokkaa]

Joskus kuvattaessa kuvien värisävyt eivät täysin vastaa kuvattua kohdetta, joten värejä on hyvä osata säätää.

Säätäminen tasojen avulla[muokkaa]

Gimp vari saatotasoilla.jpg

Gimpillä voi nopeasti korjata kuvan värejä väritasojen (en Levels) avulla. Älä sekoita näitä tasoja kuvan tasoihin (en Layers). Avattuasi kuvan valitse Taso -> Värit -> Väritasot. Jos tasokäyrän päissä on "tyhjää", tartu hiirellä päissä oleviin kolmioihin ja vedä tyhjät pois. Jos kuvan keskisävyt (käyrän keskellä) ovat liian tummat, vedä keskellä olevaa kolmiota vasemmalle. Jos taas ne ovat liian vaaleat, vedä kolmiota oikealle.

Säätäminen käyrien avulla[muokkaa]

Gimp varisaato kayrilla.jpg

Värien säätäminen käyrien avulla on tehokkaampaa kuin tasojen avulla. Säätäminen käyrien avulla antaa monipuolisemmat mahdollisuudet muokata kuvan värejä sekä tummuutta. Käyrästä voi myös tehdä selkeitä havaintoja valotuksen onnistumisesta ja siten kehittää kuvaustaitojansa.

Käytä työkalua valitsemalla Taso -> Värit -> Värintoistokäyrät. Yleensä hyvä käyrä on loivan S-kirjaimen muotoinen. Esimerkkikuvassa talvimaisema, jonka molemmista päistä puuttuu sävyjä, joten musta ja valkoinen puuttuvat. Muokkaa käyrää tarttumalla siihen hiirellä jolloin siihen tulee piste, josta käyrää voi taivuttaa. Voit myös piirtää käyrän valitsemalla käyrän tyypiksi Vapaalla kädellä.

Värivirheen poistaminen käyrien avulla[muokkaa]

Värivirheitä (esim. ihon liikaa punertavuutta) voit muokata tehokkaasti valitsemalla kanavaksi värikanava (punainen, vihreä, sininen) ja muokkaamalla sen käyrää.

Kuvan terävöinti[muokkaa]

Kuvan terävöinnin tarve riippuu kuvasta ja sen käyttötarkoituksesta. Mustesuihkulla tulostettava kuva saa olla voimakkaammin terävöitetty kuin valokuvakehitykseen menevä digikuva. Sopivat arvot löytyvät kokeilemalla. Yleisesti terävöinti voimistaa paikallisia kontrastieroja valokuvassa. Taitavallakaan terävöinnillä ei voi pelastaa esimerkiksi kuvattaessa tärähtänyttä otosta.

Terävöintisuodin[muokkaa]

Valitse Suotimet->Paranna->Terävöinti. Aukeavassa ikkunassa on vain yksi liukusäädin ja esikatseluikkuna, jonka näyttämää kohtaa saa siirrettyä kuvan vieressä olevasta nuolihässäkästä. Liiallinen terävöinti saa kuvan näyttämään epäaidolta.

Unsharp mask (Epäterävä maski)[muokkaa]

Valitse Suotimet->Paranna->Unsharp mask Aukeavassa ikkunassa voit säätää tarkemmin terävöityksen määrää. Sopivat arvot riippuvat kuvasta ja löytyvät parhaiten kokeilemalla.

  • Säde-asetus kertoo kuinka lähellä olevat pikselit vaikuttavat käsiteltävään pikseliin. Jos arvo on liian pieni, ei kuvasta tule terävää, vaikka Määrä-säädin olisi maksimiarvossaa. Toisaalta liian suuri säde luo hohtavan reunuksen kontrastirajalle.
  • Määrä kertoo kuinka paljon kontrastieroa vahvistetaan.
  • Kynnysarvo määrää kuinka pienet kontrastierot otetaan huomioon. Jos tämän asetuksen arvo on liian alhainen, voimistetaan myös ei-toivottua taustakohinaa.

Eräs tapa etsiä asetuksille sopivat arvot on seuraava:

  1. Aseta Määrä-säädin täysille, jolloin muiden asetusten säätämisen aiheuttama muutos on selkeästi huomattavissa.
  2. Lähde nostamaan sädettä nollasta ylöspäin kunnes saavutat halutun lopputuloksen ( varmistu ensin, että kynnysarvo on 0 ).
  3. Kasvata kynnysarvoa nollasta kunnes ei-toivottu taustakohina ei enää voimistu.
  4. Laske terävöinnin määrä oikealle tasolle

Kohinan poistaminen[muokkaa]

Kohinaa eli rakeisuutta kuvaan tulee kun kuvataan esim. vähässä valossa. Liiallinen rakeisuus saa kuvan näyttämään karkealta. Seuraavaa tapaa voi käyttää myös tyylikeinona, kun haluaa saada aiheestaan esille pintojen rajat ja tasoittaa samanaikaisesti pintoja (esim. kasvokuvassa iho tasoittuu ja kasvonpiirteet piirtyvät selkeämmin).

Valitse Suotimet->Tee epäteräväksi->Valikoiva Gauss-sumennus. Avautuvasta ikkunasta voit säätää arvoja, joilla määritetään pehmennyssäde ja suurin erotus. Esimerkiksi arvot pehmennyssäde=4 ja suurin erotus=40 sopivat kokeilemisen lähtökohdaksi digikuvassa.

Punaisten silmien korjaus[muokkaa]

Punaiset silmät syntyvät valokuviin kun salamavalo heijastuu silmän verkkokalvon veren punasoluista. Ilmiö on voimakkaimmillaan hämärässä, koska silloin pupilli on laajentunut ja päästää eniten valoa lävitseen.

Gimp-tasot.png
  • Kahdenna taso, tämä ei ole välttämätöntä, mutta kun muutokset tekee vain toiseen tasoon on myöhemmin helppo vertailla lopputulosta alkuperäiseen kuvaan. Tasot toimivat myös nopeana tapana palauttaa tilanne jos jokin epäonnistuu.
  • Jos "tasot"-ikkuna ei ole avattuna avaa se valitsemalla ikkunat / tasot.
  • kaksoisklikkaamalla "Tausta"-tasoa avautuu valikko, josta saat tason kahdennettua.
  • Valitse lopuksi uusi taso ja varmista, että sen vieressä näkyy silmän kuva (eli taso näytetään.)
  • Valitse silmien punainen osa (Käytä zoomia päästäksesi tarpeeksi lähelle.)
  • Tilanteesta riippuen lasso ja ellipsi ovat hyviä. Myös QMask on tehokas työkalu tarkkaan valitsemiseen.
  • Ennen valintaa voit asettaa valinnalle pyöristyksen (engl. Feather). Kun pyöristystä käytetään valinta vain hiipuu pois eikä lopu yhtäkkiä. Sopiva arvo pyöristyssäteeksi on muutama pikseli silmän koosta (kuvausetäisyydestä) riippuen.
  • Käskyllä Taso / Värit / Sävy-värikylläisyys avautuu ikkuna. Tätä ennen kannattaa kuitenkin zoomata hieman ulospäin ja piilottaa valitun alueen merkki (valkoinen katkoviiva) painamalla Ctrl+T.
  • Punaista on silmässä liikaa, joten muokataan punaisia värisävyjä valitsemalla R (Red). Värikylläisyyden ja valoisuuden saa vetää minimiin. Jos silmiin haluaa saada oikean sävyn täytyy se hakea sävy-liukupalkilla.
  • Lopuksi voit verrataan tuotosta alkuperäiseen klikkaamalla ylin taso (johon muutokset tehtiin) näkymättömäksi painamalla silmän kuvaketta tason vieressä.
  • Jos lopputulos ei miellytä voit kahdentaa alkuperäisen kuvan sisältävän tason uudelleen ja säätää Taso / Värit / Sävy-värikylläisyys komentoa uudelleen. Valinta on yhä voimassa, joten sitä ei tarvitse tehdä uudelleen.

Kauneusvirheiden poistaminen kloonityökalulla[muokkaa]

Nyt opitaan poistamaan pieniä kauneusvirheitä kuvista käyttäen kloonityökalua. Kikalla voi häivytää esimerkiksi finnin poskesta tai kaukana olevan henkilön. Myös heijastimet heijastavat usein salamavaloa tarpeettoman paljon luoden heijastimen kohdalle häiritsevän kirkkaan valolaikun, joka voidaan poistaa. Jos poistettava kohde täyttää suuren osan kuvasta, ei jälki välttämättä ole erityisen luonnollinen.

Kloonityökalu kopioi kuvadataa kuvan yhdestä osasta ja liittää sen toiseen osaan.

  • Avaa kuva ja valitse kloonityökalu (leimasin)
  • Paina Ctrl pohjaan ja valitse klikkaa kohtaa, jonka haluat siirtää kauneusvirheen päälle
  • Vapauta Ctrl ja ala maalata virhettä piiloon.
    • Kannattaa valita kloonaustyökalun asetuksista siveltimeksi "Fuzzy", jolloin tuotoksen reuna ei jää teräväksi.
    • Risti kuvassa paljastaa mitä kohtaa olet kopioimassa ja nuoli+leimasin -kursori mihin kloonaat.

Vastavaloon otettu kuva[muokkaa]

Syynä on kuvauskohteen takana oleva kirkas valonlähde (esimerkiksi pilvinenkin taivas on riittävän kirkas). Kamera säätää valoituksen keskimääräisesti oikeaksi, jolloin itse kuvauskohde jää liian pimeäksi. Tällaista kuvaa ei ole kovin helppo korjata, paras tapa olisi säätää kamera laskemaan tarvittavan valaistuksen pieneltä alueelta tai valita kuvaussuunta paremmin. Jälkikäteenkin kuvaa voi kuitenkin hieman parantaa.

Kontrasti ja kuvan kirkkaus[muokkaa]

Yksinkertainen menetelmä, joka sopii parhaiten, jos riittää esimerkiksi henkilön tunnistaminen epäonnistuneesta valokuvasta. Usein kirkkauden lisääminen koko kuvaan pilaa jo valmiiksi kirkkaita osioita.

  • Kahdenna taso (kts. punasilmäisyyden poisto)
  • Taso / Värit / kirkkaus ja kontrasti. Kontrastia ylöspäin ja kirkkautta samaten. Yleensäkin ottaen kontrastia saa lisätä useimpiin kuviin.
  • Jälleen alkuperäistä ja uutta tasoa vertaamalla saat käsityksen omasta onnistumisestasi.

Varjostus / lisävalotus[muokkaa]

Tekniikka on parhaimmillaan kun pitää valottaa tiettyä aluetta (esimerkiksi kasvoja) samalla kun loppukuva jää ennalleen.

  • Valitse varjostus/lisävalotus työkalupalkista (musta pallero).
  • Sivellin: koko riippuu täysin valotettavan osan koosta, reunan kannattaa olla pehmeä (Fuzzy), jolloin kuvaan ei jää tarkkoja rajoja.
  • Tyyppi: Värilisävalotus
  • Tila: riippuu kuvasta, kokeile kaikkia
  • Valotus: kuinka tehokkaasti työkalu tuo valoa kuvaan. Liian suuri arvo tekee kuvan luonnottoman näköiseksi, aloita vaikka 30%:sta ja muuta arvoa tarpeen mukaan.

Kuvan osan muuttaminen mustavalkoiseksi[muokkaa]

Lehmä, tausta mustavalkoinen.jpg
  • Kahdenna taso
  • Muuta ylempi taso mustavalkoiseksi
  • Taso / värit / väri-sävykylläisyys
  • Säädä liukukytkimestä värikylläisyys mahdollisimman pieneksi
  • Lisää tason maski
  • Taso / Maski /Lisää tason maski
  • Musta paljastaa värillisen alueen, valkoinen piilottaa.
  • Maalaa mustalla värilliseksi haluamasi osat, jos maalaat ohi paina "X" (valitset taustavärin ja edustavärin välillä) ja pyyhi liialliset osat pois.
  • Lopuksi vertaile kuvaa piilottamalla mustavalkoinen kuva silmää painamalla

Huom! Joskus saattaa olla järkevämpää pitää ylempi taso värillisenä.


Puhekupla[muokkaa]

Joskus kuvaan halutaan liittää tekstiä, jonka joku on (muka) sanonut. Joskus tyylikäs tapa on tehdä puhekupla tälle kommentille. Puhekupla tehdään ellipsistä, jota venytetään hieman polkutyökalulla (engl. Path)

  • Valitse riittävän iso (johon teksti mahtuu) ellipsi valintatyökalulla
  • Avaa polut ikkuna (Ikkuna / Polut)
  • Valinta poluksi (Polut ikkunan alareuna)
  • Valitse polkutyökalu ja valitse luomasi polku
  • Kumoa tekemäsi valinta (, joka haittaa näkemistä) Valitse / Ei mikään
  • Venytä polusta yhtä palleroa (ankkuri) puhekuplan varreksi (, joka siis osoittaa puhujaan)
  • Valitse varren viereinen ankkuri ja vedä ankkurin kahva ulos
  • Paina siis Shift ja raahaa molluskaa eteenpäin. Esiin tulee neliö, jota kutsutaan kahvaksi (engl. Handle)
  • Kahvan avulla saat pyöristettyä kulmia, jolloin tuotos näyttää paremmalta, väännä kahvaa ja kahden vierekkäisen ankkurin välinen kaari muuttuu.
  • Toista puhekuplan varren molemmilla puolilla ja varren päässä, harjoitus tekee mestarin
  • Varren loppu jää helposti liian teräväksi.
  • Kun tuotos muistuttaa puhekuplaa valitse polut-ikkunasta Polku valinnaksi
  • Maalaa juurisyntynyt valinta mustaksi
  • Valitse / pienennä, esim 15 px
  • Maalaa uusi valinta valkoiseksi.
  • Lisää teksi tekstityökalulla, Fontti yms. määritykset löytyvät työkalun asetuksista

Teksti varjolla ja väriliulla[muokkaa]

Lopputulos

Nyt tehdään tyyliteltyä tekstiä, jota voi käyttää esimerkiksi logoissa tai nettisivujen otsikkona.

  • Avataan GIMP ja tehdään uusi kuva. Koon voit päättää itse haluamasi tekstin perusteella, minä laitan leveydeksi 400 ja korkeudeksi 150 pikseliä.
  • Valitaan tekstityökalu ja kirjoitetaan haluttu teksti aukeavaan ruutuun. Tekstityökalun asetuksista voit valita kirjasimen (eli fontin) ja sen koon. Itse valitsin Arial Black Italic (GIMPissä kursiivi yms. tulee kirjasimen mukana, ei erikseen valittavana ominaisuutena) ja kooksi 90.
  • Luultavasti teksti on enemmän tai vähemmän sivussa, joten siirrä se kuvan keskelle Siirto-työkalulla (valitse ensin asetuksista "siirrä nykyinen taso").
  • Kahdenna tekstitaso tasot-paneelista.
  • Seuraavaksi väritetään ylempää tekstiä. Valitse väriliukumatyökalu ja muokkaa sen asetuksista haluamasi väriliuku. Väriliukuma-kohdasta voit valita valmiita väriliukuja (itse otin "Tropical Colors") vaihtoehtoisesti voit valita Edustaväristä taustaväriin ja muokata edustavärin ja taustavärin haluamiksesi. Ennen värittämistä sinun täytyy avata tasot-paneeli ja ruksata "pidä läpinäkyvyys" -valinta (löytyy toiminta-pudotusvalikon vierestä). Seuraavaksi vedetään viiva tekstin päältä väriliukutyökalulla.
  • Kun itse teksti on haluamasi kaltainen käytä siirto-työkalua hilataksesi alempaa tekstiä (varjoa) hieman tekstin alta pois.
  • Jos haluat sumentaa varjon äärirajoja, valitse Suotimet -> Tee epäteräväksi -> Gauss sumennus.
  • Jos tekstisi ympärille jäi paljon tyhjää tilaa, voit rajata turhat osat pois.

Kuvan osan värien muuttaminen[muokkaa]

Näiden ohjeiden mukaan pystyt vaihtamaan kuvan osasta väriä. Voit esimerkiksi muuttaa punaisen paidan siniseksi tai vaihtaa silmien väriä. Kuvan tummuuserot jäävät, jolloin värin muutoksesta on mahdollista saada realistisen näköinen.

Värin muuttaminen käyttäen väritä työkalua[muokkaa]

Tämä tapa on hieman yksinkertaisempi, mutta antaa reilusti vähemmän valinnanvaraa.

  • Tallenna muokattava kuva xcf:nä, jolloin tallentaminen ei vahingossa tuhoa alkuperäistä kuvaa. Tee myös kopio tasosta, jolloin voit palata alkutilanteeseen.
  • Valitse muutettava osio (Paita).
  • Jos väriä muutetaan suurelta alueelta kannattaa aloittaa polku-työkalulla, jolla saat helposti valittua suunnilleen säännönmukaisen alueen. Pienempää aluetta valittaessa kannattaa siirtyä suoraan QMaskin käyttöön.
  • Käytä Ctrl-näppäintä valitaksesi useita alueita yhtäaikaisesti.
  • Lopuksi pikamaskin avulla poistetaan valinnasta siihen kuulumattomat alueet ja lisätään poisjääneet. Vielä lopuksi kannattaa säätää QMaskin läpinäkyvyys nollaksi, jolloin näet helposti mahdolliset valintavirheet.
  • Kun valinta on hyvä, näpäytä Ctrl+t, jolloin valinnan reunat katoavat näkyvistä
  • Seuraavaksi komenna taso -> värit -> väritä
  • Sopiva väri löytyy kokeilemalla "Sävy"-liukusäädintä.
  • Varsinkin tummaa kohdetta uudelleen väritettäessä kannattaa laittaa "valoisuus"-säätimestä lisää valoa, jolloin näet tulevan sävyn paremmin.

Värin muuttaminen käyttäen väritasoa[muokkaa]

Tasot paneelista, ympyröitynä Toiminta: Väri

Tämä tapa on kehittyneempi ja antaa paremmat mahdollisuudet muokata väriä. Esimerkiksi kuvan voi värittää yhdestä kohtaa siniseksi, toisesta punaiseksi.

  • Tee uusi (läpinäkyvä) taso.
  • Väritä haluamasi kohdat toivotulla värillä
  • Valitse tasot paneelista taso, joka sisältää tiedon väristä ja aseta Toiminta: Väri
  • Ylempi taso on muuttunut väritasoksi; GIMP tutkii väritasoa ja päättelee siitä pikselin värisävyn. Pikselin tummuus ja värikylläisyys saadaan tutkimalla alapuolella olevaa tasoa. Näin kuvan luonnolliset varjo ja valokohdat jäävät näkyviin.

GIF-animaatioiden teko GIMPillä[muokkaa]

Animaatio koostuu yksittäisistä kuvista ( frameista, engl: frame ), joita näytetään nopeasti peräkkäin. GIMPillä animaatioita tehdessä jokainen taso vastaa yhtä framea.

  • Luo uusi kuva ja tee kuvaasi tarvittava määrä tasoja.
  • Aloita alimmasta tasosta, joka on animaation ensimmäinen kuva, ja piirrä siihen animaation alku
  • Siirry seuraavaan frameen ja piirrä seuraava ruutu. Mitä vähemmän animaatiossa tapahtuu framen aikana, sitä sulavampi on animaatio.
  • Kun viimeinenkin ruutu on piirretty valitse Tiedosto -> tallenna nimellä. Kirjoita tiedostomuodoksi ".gif".
  • Valitse "Tallenna animaationa" ja vie.
  • Ikuinen silmukka tarkoittaa, että animaatiota toistetaan loputtomasti
  • Mitä pienempi on tauko ruutujen välissä, sitä nopeampi on animaatio. Ihminen pystyy ymmärtämään animaation koostuvan yksittäisistä kuvista, jos ns. framerate on noin 20 tai alle, eli jos sekunnissa kuva vaihtuu alle 20 kertaa. Tätä raja-arvoa vastaa n. 50 ms tauko ruutujen välissä.

Harjoituksia[muokkaa]

Tälle sivulle kerätään GIMPillä tehtäviä harjoituksia ja esimerkkiratkaisuja. Tälle sivulle voidaan viitata kirjan muista osista.

Kahden kuvan yhdistäminen[muokkaa]

Käytetään: polkutyökalu, pikamaski, Tasot

Viedään kuvan osa (kuumailmapallo) kuvasta toiseen ja asetetaan se hieman rakennuksen taakse. Käytetään allaolevia kuvia (commonsista, klikkaamalla saat suuren kuvan)

kuumailmapallo maisema

  • Aluksi valitaan kuumailmapallo. Käytetään polkutyökalua ja hienosäädetään pikamaskilla. Koska tässä tapauksessa pallon tausta on hyvin tarkasti yksivärinen, voidaan käyttää myös taikasauva-työkalua.
GIMP-kuumailmapallon kori.jpg
    • Kun polku seurailee pallon ääriviivoja melko tarkasti komenna valitse -> polusta.
    • Seuraavaksi käytetään pikamaskia; paina Shift+Q ja maalaa mustalla ne alueet, jotka eivät kuulu palloon ja valkoisella ne, jotka kuuluvat.
    • Kun valinta on riittävän tarkka, poistu pikamaskitilasta
  • Seuraavaksi kopioidaan valittu pallo painamalla Ctrl+C ja liitetään se uuteen kuvaan painamalla Ctrl+V. Vielä täytyy muuttaa pallo kelluvasta valinnasta tasoksi klikkaamalla uusi taso -painiketta tasot-paneelista. Nimeä vielä uusi taso.
  • Yleensä liitetty kuva on väärän kokoinen, jolloin sitä täytyy skaalata. Valitse skaalaustyökalu, ota hiirellä kiinni uudesta tasosta ja raahaa se sopivan kokoiseksi. Paina vielä auennesta ikkunasta "Skaalaa". Huomaa, että alkuperäinen kuumailmapallo saattaa pilkottaa taustalta, mutta se katoaa, kun skaalaus saadaan valmiiksi.
  • Siirrä kuumailmapallo sopivaan kohtaan (tässä osittain seinän taakse) käyttäen Siirto-työkalua
Lopputulos
  • Seuraavaksi muutetaan osa pallosta läpinäkyväksi, jolloin se näyttää olevan oksan takana.
    • Muutetaan ensin koko pallon sisältävä taso osittain läpinäkyväksi Tasot-paneelin "Peitto" kohdasta.
    • Lisätään tasoon maski, komenna Taso -> Maski -> Lisää tason maski.
    • Maalataan valkoisella ne kohdat, joissa ei ole rakennusta ja mustalla ne, joissa on. Harmaan eri sävyt vastaavat läpinäkyvyyden eri asteita.
    • Esimerkissä on suora seinämä, joten voit käyttää myös polkutyökalua. Aseta polku seuraamaan seinää ja kiertämään pallon reunan "ulkopuolelta" (polun ei tarvitse seurata pallon ääriviivoja tarkasti). Kun muutat polun valinnaksi ja värität koko valinnan mustaksi, on lopputulos toivottu.
    • Lopuksi pallo-tason peitto täytyy asettaa takaisin 100 %:iin.


Osan irroittaminen kuvasta ja varjon liittäminen[muokkaa]

Tässä harjoituksessa irroitetaan kuvasta (tässä tapauksessa kukka) eräs osa (itse kukka varsineen), poistetaan loput ja lisätään kasvin taakse varjo. Kukan kuva ladataan Commonsista.

Alkuperäinen kuva
Lopputulos
  • Kun kuva on ladattu kotikoneelle (käytä suuren resoluution versiota) ja se on avattu GIMPiin, alkaa itse kuvan muokkaaminen.
  • Ensimmäiseksi kukka täytyy irroittaa taustastaan. Käytetään irroittamiseen polku-työkalua. Polkutyökalu sopii hyvin, koska kohteessa on reilusti mukavan pyöreitä muotoja.
  • Kun kukka on valittu polkutyökalulla, otetaan esiin Polut-paneeli ja klikataan Polku valinnaksi -namiskaa (punainen neliö).
  • Kun valinta on tarkka kopioidaan valinta leikepöydälle (Muokkaa -> Kopioi) ja liitetään se heti samaan kuvaan (Muokkaa -> Liitä). Tee juuri liitetystä kuvasta ("Kelluva valinta" tasot-paneelissa) oikea taso klikkaamalla uusi taso -painiketta.
  • Kun vielä piillotat Tasot-paneelista alkuperäisen kukan taustoineen, pitäisi edessäsi olla kukka, jonka taustalla on harmaa ruudukko läpinäkyvyyden merkkinä.
  • Luo uusi, valkoinen, taso alkuperäisen tason ja pelkän kukan sisältävän tason väliin. Nyt sinulla on irtileikattu kukkanen valkoisella pohjalla.
  • Valitse vastaluotu valkoinen taso ja mene Polut-paneeliin. Valitse uudelleen "polku valinnaksi", jolloin sinulla on valittuna kukan muotoinen alue.
  • Koska varjot eivät ole terävärajaisia, valitse Valitse -> Pyöristä. Pyöristyksen arvo riippuu ennenkaikkea kuvan koosta ja halutusta lopputuloksesta. Nyt 100px tuottaa sopivan tuloksen.
  • Täytä valinta mustalla (voit toki kokeilla muitakin värejä) maalilla. Käytä täyttötyökalua, varmista, että työkalun asetuksissa on valittuna "täytä koko valinta".
  • Raahaa vielä varjoa hieman pois kukan alta. Käytetään Siirtotyökalua, asetuksista valitaan "Siirrä nykyinen taso".
  • Enää puuttuu tyhjän alueen poisrajaaminen ja kuvan tallentaminen.