GIMP/Perusteita

Kohteesta Wikikirjasto
Loikkaa: valikkoon, hakuun

Tällä sivulla käsitellään GIMPin perusominaisuudet, työkalut ja valikoiden sisällöt.

Työkalut[muokkaa]

Gimp-tyokalut.jpg

Valintatyökalut[muokkaa]

Työkaluryhmän numero 1

Valintatyökaluja ovat:

  • suorakulmainen valinta R
  • ellipsivalinta E
  • Vapaavalinta (lasso) F
  • Sumea valinta (taikasauva) - väriltään yhtenäiset alueet U
  • Valitse värillä- valitsee samanvärisen yhtenäisen alueen Vaihto+O
  • Saksivalinta I
  • Edustan valinta

Kun käytät suorakulmaista- tai ellipsivalintaa, voit shift-, ctrl- ja alt-näppäimiä käyttämällä muuntaa valinnan käyttäytymistä.

  • Jos painat pohjaan ennen valinnan aloittamista:
    • Shift - voit valita lisää.
    • Ctrl - voit vähentää valintaa.
    • Shift & Ctrl - vanhan ja uuden valinnan päällekäin menevät osat valitaan.
  • Jos painat pohjaan valintaprosessin alettua:
    • Shift - tekee valinnasta yhtä korkean kuin leveän (neliön tai ympyrän).
    • Ctrl - aloituspisteestä tulee valinnan keskipiste.
    • Alt - voit siirtää valintaa.

Polkutyökalu[muokkaa]

Työkalun pikavalinta B, työkaluryhmän numero 2

Polkutyökalulla voit luoda ja muokata polkuja. Työkalu on erittäin tehokas kun tehdään valintoja, joissa on runsaasti suoria tai likipitäen säännönmuokaisesti kaareutuvia pintoja. Polut tallentuvat .xcf-muodossa tallennettujen töiden mukana.


Värinpoiminta[muokkaa]

Työkalun pikavalinta O, työkaluryhmän numero 3

Värin poimintatyökalulla voit valita kuvasta tietyn värin. Painamalla Ctrl-näppäimen pohjaan ennen kuin valitset värin voit valita ns. taustavärin. Muuten valinta kohdistuu ns. etuväriin eli piirtoväriin.


Zoom[muokkaa]

Työkalun pikavalinta Z, työkaluryhmän numero 4

Zoomaustyökalulla pystyt zoomaamaan lähemmäs ja kauemmas painamalla kuvaa. Ctrl-näppäimellä voit vaihtaa zoomataanko lähemmäs vai kauemmas. Vetämällä valinnan voi valita alueen mihin zoomataan.

Mittatyökalu[muokkaa]

Työkalun pikavalinta Vaihto+M, työkaluryhmän numero 5

Mittatyökalu näyttää pisteiden välisen etäisyyden ja kulman. Mittausta varten valitse työkalu, klikkaa ensimmäistä pistettä ja raahaa kohdistin hiiren nappi pohjassa toiseen pisteeseen. Etäisyys ja kulma näkyvät tilarivillä. Ctrl pohjassa kulma muuttuu 15° välein.

Siirtotyökalu[muokkaa]

Työkalun pikavalinta M, työkaluryhmän numero 6

Siirtotyökalulla voit siirtää tasoja tai valittuja alueita.

Kohdistustyökalu[muokkaa]

Työkalun pikavalinta Q, työkaluryhmän numero 7

Kohdistustyökalulla voit kohdistaa ja järjestää tasoja tai muista kohteita

Rajaa & muuta kokoa[muokkaa]

Työkalun pikavalinta Vaihto+C, työkaluryhmän numero 8

Rajaustyökalulla voit pienentää kuvan kokoa ja poistaa ei valitun osan kuvasta. Koon muuttaminen pienentää kuvaa poistaen valitsemattoman alueen.

Muunnostyökalut[muokkaa]

Työkaluryhmän numero 9

Muunnostyökaluja ovat:

  • kierto Vaihto+R
  • skaalaus Vaihto+T
  • vääntö Vaihto+P
  • perspektiivi Vaihto+F

Peilikuva[muokkaa]

Työkalun pikavalinta Vaihto+F, työkaluryhmän numero 10

Peilityökalu kääntää tason tai valinnan peilikuvaksi. Ctrl-näppäin vaihtaa peilikuva suunnan horisontaalinen ja vertikaalinen vaihtoehtojen välillä.

Tekstityökalu[muokkaa]

Työkaluryhmän numero T

Tekstityökalua käytetään kirjoitettaessa tekstiä kuviin. GIMPin versiosta 2.0 eteenpäin tekstit ovat olleet muokattavissa jälkikäteen. Klikkaa kuvaa tekstityökalulla ja kirjoita haluamasi teksti aukeavaan tekstieditoriin. Tekstin paikkaa voit muuttaa jälkikäteen siirtotyökalulla raahaamalla hiirellä kirjaimen kohdalta. Fonttia ja tekstin väriä voit muuttaa työkalun asetuksista.

Klikkaamalla tasopaneelista tekstitasoa oikealla hiirennäppäimellä saat eteesi valikon:

  • Tekstityökalun avulla voit korjata kirjoittamaasi tekstiä
  • Yhdistä alas liittää tekstin ensimmäiseen tekstitason alapuolella olevaan näkyvään tasoon. Tämän jälkeen et voi enää korjata kirjoitusvirheitä.
  • Hylkää tekstidata muuttaa tekstitason tavalliseksi, läpinäkyväksi, tasoksi, jossa teksti näkyy kuin mikä tahansa kuva. Valinnan käytön jälkeen tekstiä ei enää voi muokata.

Täyttötyökalu[muokkaa]

Työkalun pikavalinta Vaihto+B, työkaluryhmän numero 12

Täyttötyökalu alueen värillä tai kuviolla. Asetuksista valitaan täytetäänkö koko valinta vai alue, jonka pikselien värit ovat riittävän lähellä toisiaan. "Raja"-liukusäätimellä voidaan vaikuttaa siihen, kuinka samanvärisiä pikselien täytyy olla, jotta ne väritetään.

Väriliukuma[muokkaa]

Työkalun pikavalinta L, työkaluryhmän numero 13

Väriliukuma täyttää alueen väriliukumalla.

Piirtotyökalut[muokkaa]

Piirtääksesi suoran viivan millä tahansa työkalulla valitse aloituspiste ja pidä Shift-näppäin painettuna pohjaan.

Työkaluryhmän numero 14
  • Kynä - Piirtää teräväreunaisia viivoja. N
  • Sivellin - Piirtää pehmeäreunaisia viivoja. P
  • Kumi - Pyyhkii kuvaa korvaten poistetun osan taustavärillä. Vaihto+E
  • Ruiskutyökalu - Piirtää viivoja. painetta ja värin määrää voi säätää. A
  • Mustekynä - Piirtää vaihtelevia viivoja. K
  • Kloonaustyökalu - Maalaa käyttäen kuviota tai kuvan osia. Ctrl-näppäimellä voit määritellä kuvan osan. C
  • Sumennus- ja tarkennustyökalu Vaihto+U
  • Tuhrintatyökalu - Toimii kuten nihkeä sormi hiili- tai lyijykynätyössä. S
  • Varjostus ja Lisävaloitus Vaihto+D

Valikot[muokkaa]

Pääikkunan valikot[muokkaa]

Tiedosto[muokkaa]

  • Uusi - avaa uuden kuvan. Voit valita kuvan koon ja pohjan värin tai läpinäkyvyyden.
  • Avaa - avaa tiedosto omalta koneeltasi
  • Avaa sijainti - avaa kuvan verkkosijainnista
  • Pikavalinnat - avaa viimeksi käsitellyistä tiedostoista
  • Kuvan syöttö - avaa kuvan a)leikepöydältä (liitä uutena, leikepöydältä b)kuvan kaappaus toiminnolla voit kaapata kuvan näytöltä
  • TWAIN - voit tuoda kuvan TWAIN ajurin avulla esim. skannerista tai kamerasta.

  • Asetukset - voit muuttaa ohjelman asetuksia
  • Ikkunat - Voit avata erilaisia paneeleja,. Valikon sisältö on sama, kuin kuvaikkunan Ikkunat-valikossa.

Poistu - Sammuttaa GIMPin

Laajennokset[muokkaa]

  • Modulinhallinta –Voit määrittää mitkä modulit ladataan käynnistymisen yhteydessä tai ladata modulin.
  • Liitännäisselain –Näet mitä liitännäisiä (plugin) on asennettuna.
  • Proseduuriselain – Näet mitä proseduureja on asennnettuna.
  • Yksikköeditori –Voit muokata yksikköjä ja ottaa käyttöön uusia yksiköitä.
  • Script-fu – Sisältää monia hyödyllisiä ja helppokäyttöisiä scriptejä (komentojonoja), joilla voit helposti tehdä esimerkiksi webgrafiikkaa.
  • Split Video into Frames–erottaa videosta yksittäisen ruudun.

Ohje[muokkaa]

  • Ohje (F1) –Aukaisee ohjeen. Huom! ohje täytyy olla asennettuna (katso Gimp/Aluksi).
  • Yhteydestä riippuva avustus (Vaihto+F1) –Näyttää hiirtä klikkaamalla yhteyteen sopivan ohjeen.
  • Päivän vihje –Vihjeet, joista on hyötyä, englanninkielinen.
  • Tietoja –Näyttää käytettävän gimpin version.
  • Gimp verkossa –Linkit gimpin virallisiin verkkosivuihin.

Kuvaikkunan valikot[muokkaa]

Tiedosto[muokkaa]

  • Uusi - luo uuden kuvan
  • Avaa - Avaa jo tehdyn kuvan
  • Avaa tasona - Vanha kuva liitetään tasoksi aktiiviseen kuvaan (voit yhdistää useita kuvatiedostoja yhdeksi kuvaksi)
  • Avaa sijainti - Voit avata kuvan, joka on Internetissä tai jonka hakemistopolun tiedät.
  • Pikavalinta - Viimeksi avattuja kuvia

  • Tallenna - Tallentaa vanhan tiedoston päälle, mikäli kuva on vasta luotu GIMP käyttää automaattisesti valintaa "Tallenna nimellä"
  • Tallenna nimellä - Tallenna kuvatiedosto uudella nimellä ja muokkaa tiedostoa sen uudella nimellä
  • Tallenna kopio - Tallenna uudella nimellä, mutta jatka vanhannimisen tiedoston muokkaamista
  • Tallenna malliksi
  • Palauta - Palauttaa käsiteltävän tiedoston viimeiseen tallennukseen (Vastaa komentoa Avaa+tiedostonNimi)
  • Palauta

  • Sivun asetukset - tulostusasetuksia (esim onko paperi vaaka vai pystysuunnassa)
  • Tulosta - Tulostaa kuvan

  • Sulje - Sulkee käsiteltävän kuvan
  • Poistu - Sulkee koko GIMPin

Muokkaa[muokkaa]

Gimpin muokkaa valikko on monipuolinen ja on jaettu neljään osaan, joista ensimmäinen liittyy tehtyjen toimintojen kumoamiseen ja uudelleen suorittamiseen. Toisen osa liittyvät kopioimiseen ja liittämiseen. Kolmas osa liittyy piirtoalueen täyttämiseen ja tyhjentämiseen. Neljäs osa on kopiointi leikepöydälle ja leikepöydältä.

Muokkaa valikon toimintoja käytetään yleensä valintatyökalujen kanssa. Jos et käytä valintaa, toiminto kohdistuu koko alueeseen (kuvatasoon). Kannattaa opetella työskentelemään näppäimistön kautta, koska se vapauttaa hiiren piirtämiseen.

  • Kumoa (Ctrl+Z) –Voit kumota tekemäsi toiminnon.
  • Uudelleen (Ctrl+Y) –Voit tehdä toiminnon uudelleen.
  • Toimintohistoria –Avaa toimintohistoria ikkunan, josta voit selata tekemisiäsi toimintoja ja poistaa niitä.

  • Leikkaa (Ctrl+X) –leikkaa valitun alueen leikepöydälle.
  • Kopioi (Ctrl+C) –kopioi valitun alueen leikepöydälle.
  • Liitä (Ctrl+V) –liittää leikepöydältä kuvaan.
  • Liitä johonkin –liittää leikepöydältä kuvan valintatyökalulla rajattuun osaan.
  • Liitä uutena –liittää kuvan leikepöydältä uudeksi kuvaksi.
  • Leike –voit nimetä kopioidun leikkeen leikepöydälle ja poimia sen nimetyn leikkeen.

  • Tyhjennä –tyhjentää piirtoalueen tai valitun alueen.
  • Täytä edustavärillä –täyttää piirtoalueen tai valitun alueen edustavärillä.
  • Täytä taustavärillä –täyttää piirtoalueen tai valitun alueen taustavärillä.
  • Täytä kuviolla –tyhjentää piirtoalueen tai valitun alueen kuviolla.
  • Piirrä valinta –voit piirtää valinnan siveltimellä.
  • Piirrä polkua pitkin –voit piirtää valinnan polkutyökalulla.

  • Kopioi leikepöydälle –kopioi leikepöydälle.
  • Liitä leikepöydältä –liittää leikepöydältä.

Valitse[muokkaa]

Tästä valikosta löytyviä toimintoja käytetään valintojen hallitsemiseen.

  • Kaikki - valitsee koko kuvan.
  • Ei mikään -toiminnon jälkeen mitään ei ole valittuna.
  • Käänteinen - Valituista osista tulee valitsemattomia ja päinvastoin.
  • Kelluva -komennon käytön jälkeen valittuna ollut osa muuttuu kelluvaksi valinnaksi, eli valittua osaa voi siirtää kuvan toiselle alueelle. Kelluva valinta ankkuroidaan alla olevaan tasoon klikkaamalla valittua aluetta hiirellä, kun kursorin yllä on ankkuri tai tasot-paneelista.
  • Värin mukaan - Kuvapisteet, joiden värisävy on riittävän lähellä klikattua pistettä tulevat valituiksi. Valittu alue ei välttämättä ole yhtenäinen, kuten Valitse väriltään yhtenäisiä alueita -työkalun tekemä valinta.
  • Polusta - toiminto muuttaa aktiivisena olevan polun valinnaksi
  • Valintaeditoria voidaan käyttää mm. valinnan tallentamiseen.

  • Pyöristä häivyttää valintaa hitaasti jyrkän päättymisen sijasta. Erittäin käyttökelpoinen ominaisuus. Jos valitset pyöristä 10px, tulee osittain valittu alue 5px alkuperäisen valinnan reunoista molempiin suuntiin.
  • Terävöitä - Kumoa pyöristä-komennon vaikutus
  • Pienennä - pienentää valintaa
  • Laajenna -laajentaa valintaa
  • Reuna - Valitsee vain valinnan reuna-alueet teityllä etäisyydellä valinnan alkuperäisistä rajoista.
  • Pyöristetty neliö -häivyttää kulmat valinnasta
  • Aseta QMask- kts. QMaskin ohjeet.
  • Tallenna kanavalle / poluksi - Tallentaa tiedon valituista alueista myöhempää käyttöä tai muokkausta varten.

Näytä[muokkaa]

  • Uusi näkymä valinta avaa saman kuvan toiseen ikkunaan. Esimerkiksi toisessa ikkunassa voi näkyä koko kuva, kun taas toinessa ikkunassa muokkaat yksityiskohtaa. Muutokset näkyvät molemmissa kuvissa.
  • Piste pisteeltä
  • Suurenna xxx% - Erilaisia zoomausvaihtoehtoja

  • Pienennnä ikkuna pienentää ikkunan kuvan kokoiseksi (mikäli kuva on ikkunaa pienempi)
  • Kokoruutu - Avaa kuvan koko ruudun kokoiseksi

  • Infoikkuna antaa tietoja kuvatiedostosta ja hiiren kursorin paikasta
  • Navigointi avaa erillisen navigointi-ikkunan, josta voi hallita näytettävää aluetta ja zoomausta.
  • Näyttösuotimet sisältävät näytöllä näkyvään kuvaan vaikuttavia suotimia (leluja?)

  • Näytä valinta Piiloittaa tai näyttää valitun alueen rajat katkoviivalla. Hyödyllinen muokattaessa valintaa.
  • Näytä tason rajat - Tasot voivat olla eri kokoisia
  • Näytä apulinjat - Apuviivoja voit asettaa Kuva-valikosta
  • Naksahda apulinjoihin - Työkalut kulkevat apuviivoja pitkin, mikäli kursori menee tarpeeksi lähelle viivaa.
  • Näytä apuviivat ja Naksahda apuviivoihin - vastaavat apulinjoja
  • Oma laajennosväri

  • Näytä menupalkki - Voit kytkeä menupalkin pois päältä (Menupalkissa ovat valikot, poiskytkemisen jälkeen pääset valikoihin klikkaamalla kuvaa hiiren oikealla näppäimellä)
  • Näytä viivoittimet - Voit piiloittaa tai ottaa käyttöön näytön sivulla olevat mittatikut
  • Näytä vierityspalkit - Voit piiloittaa tai ottaa käyttöön näytön sivulla olevat vierityspalkit. Jos palkit eivät ole näkyvissä, voit valita kuvan näytettävän osan raahaamalla hiiren kolmospainikkeella tai avaamalla Navigointi-ikkunan (Näytä-valikosta).
  • Näytä tilapalkki - Piiloittaa kuvaikkunan alareunan tietopalkin.

Kuva[muokkaa]

  • Kahdenna - Avaa aktiivisen kuvan toiseen ikkunaan uudella nimellä. Voit esimerkiksi kahdentaa kuvan ennen muokkauksen aloittamista, jolloin muokkaukset eivät muuta alkuperäistä tiedostoa
  • Tila - Voit säätää miten värit esitetään.
    • RBG
    • Harmaasävy
    • Indeksoitu
    • Hajoita
    • Yhdistetään
  • Muunnos - Kuvan peilaaminen ja kääntäminen

  • Kankaan koko - Voit muuttaa kuvan kokoa siten, että osa kuvasta rajautuu pois tai kuvan reunoille tulee "tyhjää" tilaa.
  • Sovita kangas tasoihin - Kuvaa laajennetaan (tai pienennetään) siten, että kaikki tasot mahtuvat kokonaan kuvaan.
  • Tulostuskoko
  • Skaalaa kuvaa - Muuta kuvan kokoa. Kts. Ohje
  • Rajaa kuva - Rajaa kuvan valinnan reunan kohdalta. Mikäli valinta ei ole suorakaide, rajataan siten, että koko valinta mahtuu uuteen kuvaan.
Vasemmalta oikealle:Alkuperäinen kuva, Automaattisesti rajattu kuva ja Zealous Cropilla rajattu kuva
  • Kuvan automaattinen rajaus - Etsii kuvan reunuksen ja rajaa sen pois. Jos esimerkiksi kuvan reunalla on yksivärinen kehys, poistetaan se. Huomaa, että toiminto rajaa kaikki tasot, mutta tutkii vain aktiivista tasoa, mikä voi johtaa kuvadatan menetykseen. Katso myös oheinen kuva.
  • Zealous Crop - Kuten automaattinen rajaus, mutta poistaa yksivärisiä osioita myös kuvan keskeltä.

  • Yhdistä näkyvät tasot - Yhdistää vain näkyvissä olevat tasot (Tasot-paneelissa tason vieressä on silmäkuvake).
  • Yhdistä kuva - Yhdistää kaikki tasot.

  • Apulinjat - Toiminnolla voi luoda ja poistaa vaaka- tai pystysuoria apulinjoja.

Taso[muokkaa]

  • Uusi taso - Luo uuden tason vanhan päälle. Tason täyttötavaksi voi valita edustavärin, taustavärin, valkoisen tai läpinäkyvyyden.
  • Kahdenna taso - Luo vanhan tason päälle kopion siitä.
  • Poista taso - Poistaa tason.
  • Pino - Voi valita tiettyjä tasoja, jos niitä on monta päällekkäin.
  • Värit - Mahdollisuus säätää mm. väritasapainoa, sävy-värikylläisyyttä ja kontrastia.
  • Suotimet -

Työkalut[muokkaa]

Ikkunat[muokkaa]

Suotimet[muokkaa]

Script-Fu[muokkaa]

Script-Fu sisältää valmiita komentosarjoja, jolla voi helposti ja nopeasti muokata kuvaa, vaikka ei edes olisi kokemusta kuvankäsittelystä. Script-Fu toiminnot löytyvät Gimpin valikosta. Niitä käyttämällä voi esimerkiksi helposti, yhdellä klikkauksella, häivyttää kuvasta reunat tai tehdä siitä vanhan valokuvan näköisen.

Video[muokkaa]

HUOM! Tämä valikko on käytössä, kun olet asentanut gap(animaatio) paketin.

Perusominaisuudet[muokkaa]

Tasot[muokkaa]

Gimp-tasot.png

Tasoja (engl. Layer) voi ajatella ikäänkuin piirtoheitinkalvoina: osa tasosta voi olla läpinäkyvä, jolloin alapuolella oleva taso näkyy läpi. Tasot ovat erittäin tehokkaita työskentelyn apuvälineitä. Tasojen hallinta sujuu tasopaneelista käsin (kts. kuva). Muutokset koskevat (lähes aina) vain valittua tasoa. Voit esimerkiksi ottaa kuvan, luoda uuden, läpinäkyvän tason kuvan yläpuolelle ja töherrellä tähän vastaluotuun tasoon. Lopuksi voit poistaa tason ja alkuperäinen kuva on koskematon. Tasojen näppärää käsittelyä varten kannattaa pitää auki tasot-ikkunaa (kts. viereinen kuva). Ikkunassa näkyy missä järjestyksessä tasot ovat, ylempi peittää alemman, ja siitä saa helposti käyttöön halutut toiminnot.

Tason asetukset[muokkaa]

  • Peitto — Tekee tasosta läpikuultavan
  • Säilytä läpinäkyvyys (Harmaa ruudukko) — Sallii tason muokkaamisen vain jo ennestään väritetyiltä osin.

Uuden tason luominen[muokkaa]

  • Klikkaa tyhjän sivun kuvaa tasopaneelin alareunassa.
  • Uuden tason koko on oletuksena koko kuvan kokoinen.
  • Taso kannattaa nimetä kuvaavasti, ainakin jos teet suurempaa projektia.

Tason poistaminen[muokkaa]

  • Raahaa poistettava taso tasopaneelin alareunassa olevaan roskakoriin.

Tason kahdennus[muokkaa]

Tason kahdennus luo tasosta kopion, joka sijoitetaan kopioitavan tason yläpuolelle. Tasojen kahdennusta voi käyttää esimerkiksi kun tekee muutokset tason kopioon on myöhemmin helppo vertailla lopputulosta alkuperäisen kuvan kanssa. Tasot toimivat myös nopeana tapana palauttaa tilanne jos jokin epäonnistuu.

  • Jos "tasot"-ikkuna ei ole avattuna avaa se valitsemalla ikkunat / tasot.
  • kaksoisklikkaamalla "Tausta"-tasoa avautuu valikko, josta saat tason kahdennettua.
  • Valitse lopuksi uusi taso ja varmista, että sen vieressä näkyy silmän kuva (eli taso näytetään.)

Tason maski[muokkaa]

Tason maskin avulla voidaan helposti määritellä mitkä osat tasosta ovat näkyvillä.

  • Taso / Tason maski / Lisää tason maski
  • Piirrä tavallisilla piirtotyökaluilla, musta väri vastaa läpinäkyvää, valkoinen läpinäkymätöntä ja eri harmaan sävyt läpinäkyvyyden asteita
  • Voit käyttää värittämiseen eri siveltimiä, liukuvärjäystyökalua, tai väritystyökalua.
  • X:ää napauttamalla voit vaihtaa edusta ja taustavärit keskenään. Tällöin voit vuorotellen poistaa ja lisätä tason läpinäkyviä osia.

Polkutyökalu[muokkaa]

Polkutyökalulla luodaan polkuja (engl:Bezier Path), jotka ovat ikäänkuin tallennettuja hiiren liikkeitä. Polkutyökalut ovat omiaan mm. tehtäessä valintaa alueesta, jonka reunat ainakin suurimmaksi osaksi ovat suoria tai likipitäen säännönmukaisia kaaria. Polkutyökaulua käytetään monesti esimerkiksi epätarkkojen logojen muuttamiseen tarkoiksi. Tässä tapauksessa polkutyökalulla piirretään kuvan päälle.

Polkujen luominen[muokkaa]

Polku koostuu kulmista eli ankkureista, jotka ovat yhdistetty toisiinsa käyrillä. Luodaksesi polun valitse polkutyökalu. Klikkaamalla kuvaa saat asetettua uusia kulmia. Kun käyrä on valmis voit yhdistää polun alun ja lopun toisiinsa painamalla Ctrl ja klikkaamalla ensimmäistä ankkuria (Kursorin oikeassa yläkulmassa on ylösalainen U (=magneetti?)). Huomaa, että polkua ei ole pakko sulkea.

Ankkureiden hallinta[muokkaa]

Yksinkertaisimmillaan yhtä ankkuria siirretään raahaamalla se haluttuun paikkaan. Käyttämällä Shiftiä voidaan valita useita ankkureita, joita siirretään kerralla. Koko polkua voit siirtää painamalla Alt-näppäintä. Kulman voit poistaa painamalla pohjaan Ctrl ja Shift näppäimet tai valitsemalla halutun kulman ja painamalla Delete.

Kahvojen hallinta[muokkaa]

Yksinkertainen polku

Kasa toisiinsa suorilla viivoilla yhdistettyjä pisteitä ei ole erityisen käytännöllinen, mutta polkujen vahvuus piilee siinä, että voit määrittää mihin suuntaan kulmasta lähtevä käyrä suuntautuu. Pidä Ctrl pohjassa ja vie hiiri kulman päälle. Kun kursori muuttuu sormella osoittavaksi kädeksi paina hiiren nappi pohjaan ja vedä kulmasa ulos kahva (engl: control handle). Jos hiiren kursori ei muutu on luultavasti polkutyökalun asetuksista ruksittu kohta Lisää uusia kulmia. Kahvan suunta kertoo mihin suuntaan käyrä jatkaa matkaansa lähtiessään kulmasta, kahvan pituus kertoo kuinka pitkälle tähän suuntaan on kuljettava ennen kuin käyrä saa jatkaa matkaansa seuraavaa kulmaa kohti. Jokaiseen kulmaan kuuluu kaksi kahvaa (joista osa voi olla kulman kohdalla, jolloin ne eivät vaikuta polun kulkuun.) Liikuttamalla kahvaa Shift pohjassa saman kulman toinen kahva siirtyy ensimmäisen kanssa symmetrisesti. Vain valitun kulman (ympyrästä vain ääriviivat) kahvat ovat näkyvissä. Erityisesti polkutyökalun kanssa on huomattava, että vain harjoitus tekee mestarin.

Polkutyökalun asetukset[muokkaa]

Muokkaustilan arvona voi olla jokin seuraavista:

  • Suunnittele — Käytetään luotaessa polkua ja säädettäessä kahvoja.
  • Tässä tilassa käyrän raahaaminen muuttaa käyrän molemmissa päissä olevien ankkureiden kahvojen tilaa. Shift pohjassa kaikki neljä (kaksi kahvaa kahdessa ankkurissa) kahvaa liikkuvat
  • Muokkaa (Vaihtoehtoisesti pidä Ctrl pohjassa) — Voit lisätä polkuun ankkureita klikkaamalla polkua
  • Siirrä — Siirtää polkua kokonaisuutena, sama vaikutus on jos pitää altin pohjassa ja raahaa polkua.

Valinnan luominen polkutyökalulla[muokkaa]

Valintaa tehdessä kannattaa ankkurit sijoittaa valittavan alueen kulmakohtiin. Ankkureita ei kannata käyttää liikaa, sillä jokainen ankkuri tarkoittaa uusia kahvoja säädettäväksi. Monesti valintaa joutuu hienosäätämään vielä esimerkiksi pikamaskin avulla. Kun polku vastaa mahdollisimman hyvin valittavan osan reunoja komenna Valitse -> polusta tai klikkaa vastaavaa kuvaketta tasot-paneelissa.

Pikamaski[muokkaa]

Pikamaski tai QMask (engl. Quickmask) on tehokas työkalu epäsäännöllisten alueiden valitsemiseen. Pikamaski on parhaimmillaan kun hienosäädetään valintaa, esimerkiksi reunoista, kun ensin on tehty varsinainen valinta.

  • Tee ensin valinta normaaleilla valintatyökaluilla
  • Klikkaa kuvaikkunan vasemmassa alareunassa olevaa katkoviivaneliötä.
  • Valittu osa näkyy normaalisti, valitsematon osa on läpikuultavan punaisen kerroksen alla
  • Nyt voit tarkasti värittää juuri haluamasi kohdat, musta väri pienentää valintaa ja valkoinen kasvattaa.
  • Kun olet valintasi tehnyt klikkaa uudelleen QMask kuvaketta ikkunan alareunassa

Pikamaskin asetukset[muokkaa]

Pikamaskista voi säätää muutamaa näppärää ominaisuutta. Kaikki löytyvät kun klikataan oikealla hiirennäppäimellä QMask -painiketta.

  • Maskaa (eli väritä) valitut alueet / valitsemattomat alueet.
  • Aseta väri ja läpinäkyvyys.

Kelluva valinta[muokkaa]

Kelluva valinta (engl: floating selection / float) kelluva valinta on erikoinen taso, joka luodaan joskus automaattisesti ja jonka voi tarpeen vaatiessa luoda itsekin. Kun kelluva valinta on luotu, ei muita tasoja voi muokata ennen kelluvan valinnan ankkuroimista.

Kelluva valinta luodaan automaattisesti, kun valittuna olevaa kuvan osaa siirretään. Siirto tapahtuu viemällä kursori valinnan sisään ja raahaamalla valintaa. Kyseessä siis ei ole valinnan siirtäminen (alt-näppäin pohjassa). Kelluva valinta luodaan myös kun kuvaan liitetään (muokkaa -> liitä) osioita. Tavallisen valinnan voi muuttaa kelluvaksi komentamalla Valitse -> Kelluva.

Kelluva valinta liitetään alla olevaan tasoon komentamalla taso -> ankkuroi tai menemällä tasot paneeliin ja klikkaamalla hiiren oikealla näppäimellä kelluvaa valintaa ja valitsemalla "Ankkuroi taso". Halutessasi ankkuroida kelluvan valinnan uuteen tasoon komenna Taso -> uusi taso.

Valinnan tallentaminen[muokkaa]

Joskus epäsäännöllisen kappaleen tarkkaan valitsemiseen kuluu runsaasti aikaa ja joskus valinta onnistuu niin hyvin, että sen haluaa tallentaa muuten vain.

  • Valitse / Tallenna kanavalle
  • Kun haluat avata tallennetun valinnan mene Kanavat-ikkunaan ja klikkaa oikealla valintaasi. Valitse Kanava valinnaksi.


Kirjan GIMP osiot

EtusivuKäytön aloittaminenPerusteetKuvan rajojen muokkausYksinkertaista kuvankäsittelyäHarjoituksiaTulosta